Armory API not working for most of my characters


I have a bit of an odd problem with my world of warcraft account: basically, most of my characters’ armory appears to be broken such that when one tries to scrape data on them from the armory API it doesn’t work. This means that the characters don’t appear on, for example (this will probably make pugging a big problem for me from this week), or another example is a spreadsheet my raidleader has made to track our reputation progress this patch that can’t see my character, and another one is that I can’t import my characters into wow model viewer for 3D printing.

As you can probably see, I have been running into more and more issues due to the API not working for me, and was wondering if we could get this fixed? The character I am having the most problems with is Televisions - TwistingNether EU, and I first noticed the issue around December I think? About the same time that I transferred a few characters from my other wow account to the one Televisions is on. The bug is occurring on most of my characters but notably not on the ones which I transferred to my main account.

I submitted a ticket and was directed to the website bug report forums, which don’t exist on the EU forums so I’m posting here.

The website which is bugged is the world of warcraft armory:

You can see an example of data from the API not loading for my characters by searching for televisions on[0][contains]=televisions

Note: this is NOT a problem with specifically and therefore NOT a third party problem. The armory API is what is not working for me.


Have you tried to refresh the blizzard account data from the RIO site? In the support article, they mention if that doesn’t work, you can also try to contact them and they will look into things on their end.

I have tried many times over months. It is important to understand, however, that it’s not just that can’t see my characters; every single thing I use which takes data from the armory API can’t retrieve my character information, and it’s the characters which I didn’t move which are the problem.

I did notice you mentioned it was for the other characters, but still figured it was worth a shot to ensure you refreshed the data there. That’s very odd, hopefully you can figure it out.

Definitely something screwy going on with the Armory. Looking up several of my 60 level characters, it can’t find them.

With “Gnomor”, for example, shows 7 of them across various realms with option to View All 12 Results. Clicking on that though, says it’s displaying “1-0 of 12 Results” and still just shows 7.

Other of my alts on same realm and same guild work normally.

EDIT: Just noticed that if I click on thumbnail portrait accompanying this post and click on “View Profile”, it finds the character in Armory with no problem.

Yea, this is rather annoying. I was trying to refresh my character list on WarcraftLogs and it appears that 90% of my characters just no longer show up in the armory and aren’t visible characters on my account even though I can still playing them etc etc. I’m guessing armory is just taking a dump?