Addons button not appearing

I’ve got a few addons located in my Addons folder and got them setup during the last stress test.

However, at some point in the last few days the addons button, the one located on the character creation screen, has disappeared.

I just went thru all my addons removing them 1 at a time from the addons folder to see if it was one addon causing the issue, but none of them seemed to be the culprit.

I uninstalled and re-installed already, but no luck.

Any ideas?

Wouldn’t worry about it until after you actually login to play. Sure they’re just fine tuning a bit.

1 Like

I just looked, to verify for you. Mine show up just fine.

1 Like

Sooo, I was thinking the same thing, but I also tried out an addon package called Abyss UI or something along those lines. The package replaces the whole interface folder and when I have the the Abyss UI interface folder in my classic root folder, the addons button shows up and displays the 2 or 3 addons associated with the Abyss UI package.

i just installed a bunch of addons this AM and i can see the addon button right now on the login screen and all of them showing as ready to load.

not sure what your problem could be. but it is definitely still working as expected on my end. just sharing.

1 Like

Thanks! Its gotta be something with the interface folder that I replaced with this Addon package. I would have thought the re-install would of fixed that tho, because I made sure not to replace the interface folder after the re-install and just placed the individual addons I wanted into the addons folder. They didn’t show up when do that either tho.

I had this same problem yesterday.

Open your addons file. And see if it is just another extension file.

For example I downloaded Elvui but no add on button. I had to remove Elvui folder and open it and take out the other Elvui folder and put that in my add on folder.

Like some of them are a folder in a folder

5 Likes

Just an update for everyone who responded or runs into this issue.

I completed deleted the Interface folder and created a new Addons folder within there. I re-downloaded the addons that I was having issues with before and extracted the downloaded zip into the newly created Interface/addons folder. This seemed to do the trick.

The addon folders were somehow affected by the Addon package I downloaded that replaced the whole interface folder.

Removing the Interface folder completely and re-downloading the addons seemed to resolve the issue.

Thanks for the help!

best answer… it was just a folder in a folder and the game didnt detect that

1 Like

Agreed! Great response! Saved me, though I may have tried this soon anyway.

For folks like me who are coming back for Classic, remember that there is the Interface\Addons folder for WoW and a separate one for Classic\Interface\Addons\

I missed it several times

when using your extractor make sure you uncheck the box that asks you to name the folder and just extract directly into the interface or the addon folder.

THANKS SO MUCH! Very Very helpful, after 2 days trying to figure out houw to get that button back it fixed it.

For my Mac (Catalina), the path was:
/Applications/World of Warcraft/_retail_/Interface/AddOns