Acceleration Issue

Within the past week, ever since the latest patch (last Tuesday?), my computer has been experiencing a curious heavy acceleration of its fans, cpu and/or gpu. It’s never happened with wow prior to this patch, and I find it extremely unlikely my system would become behind the curve as it were literally overnight. My computer now behaves like it did the first time I tried BG2. Badly. Extreme acceleration of the system like it’s trying to run a game it can’t. When I’d exit the game, fan speeds would slow and return to normal. This is exactly how my computer responds to wow now. I don’t understand. It’s not hot in my room; it’s winter outside and only 66 in my room, so it’s definitely not room temperature. I just cleaned it thoroughly too. It needed a good cleaning and got it. So, it’s not neglect.

I can still play wow, but I fear for my system. Sure, it’s getting a little long in the tooth (2017), but it’s still a really strong computer, one that has happily chugged along, certainly capable of surpassing any technical requirements wow may have required…until now.

So Blizzard, what changed? What was in that patch that so dramatically affected my machine literally overnight? I’m at a loss how to fix it, if there even is a fix. I’ve tried adjusting in-game settings. I’ve tried defragging, file cleanup, and ending internal computer processes. Any other ideas that don’t include a full system upgrade? Thank you.

The reps in the forum are not developers and won’t be able to answer what software changes happened between patches. As for the volunteers here, we can’t troubleshoot for you without any system information. Add your DxDiag per the sticky thread instructions.


Thank you for the elaborate response, Elocin. After much hair pulling and several hardware adjustments, I found that the issue wasn’t the patch at all, so apologies to Blizzard. I had to reset the system; something affected it internally, but now is resolved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.