Warcraft Reforged Won't Launch on Mac

Hello, I downloaded Warcraft Reforged (using an old CD key), and installed it on my Mac running 10.13.6. It will not launch, giving the error “The application ‘Warcraft III Launcher.app’ can’t be opened.”

I also tried launching it from the Battle.net app, and tried repairing it through that app, no luck. I also tried installing it on another computer (running MacOS 10.11), and that had the same problem.

Here is one of the recent error logs. Any help would be appreciated!

MacOS 10.13 is the earliest supported version. Ensure your system meets these requirements

Operating System
macOS® 10.13 (latest version)

Intel® Core™ i5 or better

NVIDIA® GeForce® 750M or AMD™ Radeon™ R9 M290X or Intel® Iris® Graphics 540


30 GB HD space

Broadband Internet connection

Keyboard and mouse

800 x 600 minimum display resolution

Hi CaptainJack, and thank you for the reply.

My computer meets the requirements, as it is running 10.13, has a 3.2 GHz Intel Core i5, 24 GB of RAM, plenty of HD space (about 1 TB free), a broadband internet connection, and yes, a keyboard and mouse. =)

I certainly would hope my computer meets the requirements to play a 20-year-old game (in low/original graphic version)! (Of note, the original edition of WC3 does run just fine, I wonder if there is any conflict between the 2 programs though?)

The system requirements are independent of the graphics mode, because the new chromium-based UI is very demanding. many people will find the menus choppy even if the game itself plays fine.

Other than not meeting the requirements though, I can’t be sure. A lot of people seem to have trouble getting the game running on MacOS, but in the threads posted I haven’t seen any recurring patterns or themes. I would probably go ahead and skip straight to a support ticket, though you may get a blue response here at some point.


What is your Model Identifier?

We have a known issue with specific older Macs not launching the game. Updating the OS may help for users who can. This is currently under investigation.

Thank you!

Hi Zuvykree, thank you for your response.

My model identifier is: iMac (Retina 5K, 27-inch, Late 2015), MK482LL/A

The graphics are listed as: AMD Radeon R9 M380 2048 MB

I am currently running Mac OS 10.13.6. I submitted an error log with more info in the initial post.

Thank you!


What drive is the game installed? Have you tried reinstalling it to the Applications folder?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.