My WC3 is unplayable, black screen on launch

I have reinstalled my Windows 10, manually updated the Nvidia driver, used the windowed mode, ran as administrator, turned it off and on again, and still nothing. PTR doesn’t work either.

Both SCR and SC2 work flawlessly (SCR worked even before the reinstall, but SC2 was partially broken, now SC2 is fixed, and WC3 has a black screen).

Before the reinstall, WC3 had a different problem - not a black screen, but downloading maps in the wrong folder, and being completely broken, with settings not saving and the queue not starting. No idea whether that’s related to the current black screen issue (the previous one got resolved).

1 Like

I mean, they are entirely different games on different engines, so there is no correlation. but w/e

This is a common issue, there are multiple threads about it in the tech support forum, read through those and you may find a solution that works for you.


A common issue? I have found nothing on Reddit and Discord. This post was actually posted in the tech support section, but moved into general.

Literally everything I have tried has failed. Just now I’ve disabled all non-Windows processes and rebooted the PC, and it’s absolutely the same - black screen. Any ideas?

There’s multiple threads about it in tech support with multiple complaints in each one.

Are you certain your system meets the system requirements? If your system has multiple GPUs, i.e. integrated and discrete, make sure to disable the integrated graphics.

1 Like

Absolutely no manipulations with display adapters have yielded any result. Just now I’ve disabled the integrated graphics card, to no avail. I have updated the drivers manually. I have selected the specific .exe as the one to run with the Nvidia card. It’s all the same.

It worked even on an external drive in early September, that’s the weird thing. Back in April my internal hard drive failed, no idea whether that’s relevant, I’ve reinstalled Windows 10 LTSC in October.

I don’t think it will have anything but supposedly there’s a launch command you can use -directx12/11/9 or something like that. Far as I know the game doesn’t actually support dx12 but if you research this, theres some possibility it might work.

Outside of that, given what you’ve said I can only suggest updating to windows 11. It’s in a good spot now, there’s little reason not to. It’s even an odd numbered windows edition…
That still may or may not do anything.

Did you try deleting the game’s settings file as described here, given that you’ve seen the thread?

I don’t seem to have War3Preferences.txt? And after I removed the -window command from the launch settings, it still launches windowed. So there’s an issue there, too. At least, it doesn’t spam with downloaded maps my root folder as before.

-directx9 command in the Bnet launcher settings?

It changes the setting when you do that, so it makes sense that it stays the same. If you ever had the game run correctly in the past,that file is somewhere. Do a system wide search for it.

…It was in Documents/Warcraft 3. Anyway, now it no longer launches windowed, but the problem persists. The PTR doesn’t work either.

I’m running out of ideas. What changes, no matter how trivial, have occured since the last time you played and it worked? any new hardware? driver updates, etc?

1 Like

Try to install Battle net than the game on different computer, (ask a friend to let you try) log-in an play one game. Like this you make sure is not your account or game installation procedure. Finally you can Log-off + uninstal on your friend’s computer.

Then try to check your hardware, maybe some component is below specs or underperforming (bad drivers etc), check your internet speed, but if you are right and

then on your friend computer should do the same => ending up not working there also.

If results are negative also on second computer. or in either case:
You can open Support Ticket => Technical => Contact support => Install or patch problem

1 Like

Every other game is fine, including SC2, and it literally worked with no issues.

I don’t have friends (lmao), but I do have an old laptop with a failed fan, I could install it there… Even though I’m not too sure about the point?

The downloaded maps is an issue long since gone. I did open a ticket earlier this month, but it was due to that issue, and I thought the culprit was my external drive. But now I’ve reinstalled Windows and installed both Bnet & WC3 on my C: SSD…

Wouldn’t it be worse for WC3 as a legacy game? And isn’t Win11 even more annoying with ads and updates?

Anyone’s laptop/PC from your family, or ask neighbours; go out make 1-2 friends in school or workplace you working, or go to a local IT repair shop then for some money they will offer a minimal assistance, a try-out at least.

For sure you have a solution to try it from someone else laptop/PC (but let-s say try on newer than 2017)!

This game has decent system requirements even if their video card will work on High, than choose Menu->Options-> Graphical Quality = LOW and is enough for a try-out.

Because as you said you have installation issues:

  • Check if laptop have the right Date/Time (is a common source strange issues).
  • Check your drivers - maybe a driver update helps (Check Device Manager for some “?” symbol).
  • Than BattleNet starts properly, check inside Battle Net app:
  • can log in your account (up Right corner you should see: “Adunai Online and green dot”)
  • and than locate the right game (Down left corner - Game Version Warcraft III Region: Europe Version - Blue big Play button appears)

than if everything is fine, and still not working, or also an Uninstall War3 => Registry clean => Restart => Re-Install can work. If all fails: open ticket like I said or visit Local IT shop ask their help.

Yeah, that’s unrealistic, haha. I am trying to install it on my half-dead Windows 7 laptop. But what can be next? Let’s suppose, it runs, so what?

Where options do you mean? In-game? There’s the black screen issue on launch.

It was cleaned upon the Windows reinstall. And I checked the %AppData% folder for any trace of previous installs - nothing.

1 Like

Forget about that older computer with Win7.

  1. Go out ask somebody - sure you have local IT shop somewhere, or in some big computer store some clerks are eager to help for some extra bucks (after their working hours)

  2. Open support ticket to blizzard like I said before just will take more time to have a solution.

Warcraft 3 Reforged is not a “legacy game.” It runs on and is officially supported for Windows 11. I’ve been doing so since it (win11) came out.

Other games working does not mean there is no system related issue. This is a common tech support response (Yes, I’ve worked in it before) and other games/programs working or not working is mostly irrelevant to why this particular piece of software isn’t. There can be configuration problems, hardware problems, etc. that only affect one or a few pieces of software.

And if you’re trying to run the game on a “half dead computer” running Windows 7, which is obsolete and no longer supported, well… there are definite potential system issues, no matter what other games work.

Anything that Windows does with ads can be turned off, I have no ads anywhere in Windows that I wouldn’t have on any other major Windows release. I don’t find Win11 any more annoying to use than 10 or 8 before it.

Update! I’ve finally gotten to following the instructions, and it was indeed the Intel driver! Not too sure why, as I’m not using the integrated graphics card, but whatever. Yes, it works, the US support pinpointed it immediately.

1 Like

The game likes to use your onboard graphics no matter how badly you want it not to. The only real solution if it’s doing that is to disable it entirely. Of course, on a laptop this may be undesireable, and i’ve seen complaints about people in t hat situation when it was suggested they do this.

I honestly should have thought of th is before, but usually this is a laptop scenario and it didn’t sound like that was your setup.

1 Like

It seems Warcraft III dropped support for Direct3D9 from a certain version since even with the command line “-graphicsapi Direct3D9” on Blizzard App, the Warcraft III.exe only invokes D3D11.dll instead of D3D9.dll; however I’m not sure if the game will emulate some of Direct3D9’s properties with that command line.
Btw from another certain version the staff added support for Direct3D12, although I don’t know to what extent; but if you input the command line “-graphicsapi Direct3D12” the Warcraft III.exe will invokes D3D12.dll, and with this command line there is some distinction in the gameplay experience for me and some other players.

1 Like

I don’t think that command ever actually existed, of course it won’t do anything because it’s not nor was ever an actual thing.

1 Like