Misconceptions crash

Anyone also crash on the first blood elves mission? After 10mins, if I move the minimap it crashes. If I load a previous save I can go a bit further, but I still crash. Impossible to finish the mission.

5 Likes

This mission also crashed to desktop after playing for some time (at the point when I built the base it crashed). The workaround setting particles to medium didn’t help for this mission. Can’t progress any further now.

2 Likes

Yep, the mission doesn’t work for me either.

Yea I am having the same issue on my end as well. I tried adjusting anything I could with graphic settings or any PC settings I could think of to try and help. Nothing. Still crashes.

Spell effects to low, and you’re not loading from a save?

Not sure want exactly helped, but managed to finish the mission.
I had a lot of crashes and tried to lower the graphical settings. Also killed almost every other programs in the backround and gave high priority to warcraft 3 task in task manager.

So after a few attempts i had no crashes in the last 20 minutes of the mission.

(Someone said on another forum that a video card driver update may also help)