Maximizing multiboard leads to freezing game (1.33)

since 1.33 my game freezes on maximizing the multiboard (maybe the new font?).
I have opened a thread on Hive but cannot include the link and cannot upload the map here.

It seems to be the number of columns but it worked with the old version of Reforged before 1.33. The multiboard has 26 columns. The game is not really freezing but lagging for a very long time. Just search, download and test my map World of Warcraft Reforged 2.0 or 2.1. It definitively worked before 1.33 since 2.0 has been released long before this update.

There seems to be some bad complexity going on when rendering a multiboard for the first time with a “high” amount of columns. The computation time grows exponentially and on an empty map with 26 columns and 1 row, the board being empty, it takes my laptop a bit over a minute to show it.

You can check to see if the font adjustment is involved, there is a launch option to return to the default character kerning, it’s in the patch notes I believe.

I have tried it with the option and had the same issue but maybe I configured it wrong. You can just try it with my map World of Warcraft Reforged 2.0.

The text during gameplay will look slightly different with the launch option, if it doesn’t look different at all, you may have typed it wrong.

Even if I typed it wrong and it should work with the legacy font, it is still a bug. You can’t tell players to use this option for your map before when hosting it in

1 Like