LAN Games: Incorrect Password (!?)

I just bought WC3 Reforged for me and my daughter. However, we are unable to create a LAN game - we keep getting “The password you have provided is incorrect. Please try again”. Of course trying again does nothing.

If the game is broken and cannot allow 2 players to play a game together, then I would ask for a total refund. What a shame! It used to be a good game.


What, exactly, step by step, is your flow?

1- Start WC3 on both computers on the same LAN (2 meters from each other).
2- Press LAN, create private game on computer 1
3- Game shows on computer 2, click join and then receive “The password you have provided is incorrect. Please try again

That’s it. Tried vice-versa, same problem. No visible network or internet issue - turning off firewalls makes no difference. Many non-Blizzard posts mention that the game is broken, that LAN was purposefully disabled - but it wouldn’t make sense as 1) that’s the main way WC3 used to be played, 2) the function would be removed.

So trying to find the bug.

I also submitted a ticket (not via web technical support, as that’s broken too apparently) and sent requested files. “You can’t submit this ticket. An error has occurred. This may be a temporary error, so please try again later” Tried yesterday, this morning, from 2 computers, 2 browsers, followed instructions to the letter. Still same error.


LAN did have known issues causing it not to work for a period of time in the past, but that was fixed with 1.33.0 hotfix—no current bugs with this feature are active. Given you could see the game but got an error the password was wrong when it wasn’t and you couldn’t submit a ticket, this is more likely a connection issue. It’s possible a router issue is occurring, such as security being too strict. I recommend consulting the Internet Service Provider to see if they can factory reset the modem/router set them back up with standard settings, and ensure firmware is up to date.

Thank you.

Don’t set the game to private.


There is no reason to set a LAN game to private unless it’s some big LAN party or something and multiple games are being played. Even when you’re online, if you’re in the LAN game list, your game isn’t going to be seen by anyone that isn’t on the network.

Thank you all.

After having factory-reset my router, and prioritised game ports (open-NAT, game-boost, allowed some IP ranges, etc.), I can confirm that the issue appears to be linked to setting LAN games to ‘private’. For some reason, it doesn’t like some password when joining a private game (unsure which one).

If this function doesn’t work, maybe it should be removed (or fixed).

Thanks everyone for your helpful comments.

From Blizzard Support:

Digging into this issue the first thing we want to do is when creating a game make sure to not set it to private and see if that works. This is likely just an issue with the game password and not setting to private should work around that.

This can also be due to both players not having the map downloaded if it’s a custom map.

Hopefully those two things help out. If you need any additional assistance please send us a screen shot of the setup for the game you are trying to play, multiple screenshots are fine to show all steps.

Some special characters may not work in passwords, possibly. But it’s like we said, there’s little reason to create a password protected game in LAN play in generally

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.