FPS stutter every 2 seconds

Getting very annoying FPS stutter every 2 seconds or so. My computer is quite decent, I run a lot of new games on ultra, but this game runs terrible on my computer and I don’t know why.

Specs:

Ryzen 7 1700X
GeForce GTX 1070 8GB
3000MHZ 16GB RAM
Windows 10 64 bit pro

And it is installed on SSD.

1 Like

hey, same here… i have this one stutter every few seconds that is super annoying and kills the game to me :frowning:
i’ve had this stutter since the first beta and also the original warcraft 3 has the same stutter.

so the game runs flawlessly at 60fps but once in a while, once every few seconds it minifreezes and drops frames to sometimes 57fps, other times to 54 fps or even 51 fps… just for a second but this minifreeze is extremely annoying.

i tried everything to fix it and its impossible. i tried by setting the game to high priority and to low priority. i disabled fullscreen optimizations, i set it to win7 compatibility mode. i disabled 8 of my 12 cores. nothing helps and nothing works :frowning:
my system is a ryzen 2600x with 16gb ram, a gtx 980ti with a very recent driver and the game is installed on my samsung 960 evo nvme ssd !!

for testing purposes i tried moving the game to my hdd and there, this one stutters is even worse, it drops to even 30fps for a second and the minifreeze is even worse.

it can’t be my system because all other games run flawlessly, including wow which runs with constant 60fps and a constant 16.6ms frametime everywhere except boralus harbor, completely maxed out !!

i hope blizz can finally fix this issue because i can’t enjoy the game like it is now :frowning:

best regards
monzun

2 Likes

hey i just noticed something. i switched to the classic graphics and it works without the stuttering… flawlessly… so something about the reforged graphics is really messed up and buggy :frowning:

considering i had this since the first beta in early november 2019 i kinda fear the devs won’t fix it ?!?

I switched to classic graphics and I had an FPS of 350 but still stuttering. Bit less but still there.

This is the issue I’ve been having, the mini-freezes. My hardware isn’t as good but it seemed like the game was running fine except for that. I should test it with classic graphics, but I have a feeling the issue will disappear like yours.

1 Like

Im getting this too, reinstalling on a ssd but i really shouldn’t have too, my pc isnt godly but its high mid range and this game really isn’t visually impressive, it looks worse then starcraft 2 and i run that on extreme no issues.

yeah i agree. it looks much worse than sc2 and runs so horrible. sc2 also is 9 years old. its shocking, the game technically is still an alpha version :frowning: it should have been in developement for at least another 6 months, if not more before release. now they released a broken mess.

i can’t even start playing the campaign because the first mission is instantly failed LOL. gamebreaking bug here before the first mission of the campaign. gg blizzard

Im having the same issue. I can run red dead redemption 2 no problem but my computer struggles to maintain a decent FPS in WC III reforged…
I notice every 3-8 seconds a FPS snag (the whole game locks) then goes back to normal.
There is clearly some optimization issues or something happening! Please fix this because its really hurting my gameplay experience!

I’m having this issue as well. Every few seconds it stutters. Definitely not an issue with my PC.

Makes the game unplayable.

I’m on Mac and this exact issue has started to happen to me too as by recently. Stutter lag every 5 second or so. This happens 80% of the time I start the game. I have tried every possible solution, from changing resolution of the screen in System Preferences and in-game to the absolute lowest resolution, to cleaning up my hard-drive and closing all other programs and applications.
This lag Kills the gameplay totally and drives me totally nuts. I love playing Dota but with this lag competitive gameplay becomes a joke. I’m about to uninstall this game.