Constant disconnects during games - Game unplayable

I don’t know if it is related to the latest patch, but I didn’t have this issue before. Almost every “ranked” game I play I keep getting “Game Desync Detected by player […]” and my player tag instead of […]. It is so extremely frustrating, this only seems to happen when the game is about to end, costing you a win. I would say this happens about 50% of the times I play. I don’t have any non-roman letters in my Windows user name, as some have suggested here. I am playing WC3 classic.

Also, this bug doesn’t seem to be in the issues list. Am I the only one having this?

4 Likes

You’re not alone.

2 Likes

Yep, you’re not alone. I just asked about this is in a new thread, hoping for some response from a blueposter.

1 Like

Actually it’s not just desync, sometimes I just get logged out and lose Battle.net connectivity, sometimes it just hangs a few seconds and quits to the scoreboard without any message.

Yeah, seems indeed that I’m not alone:
Blizzard Botches First Major Warcraft 3 Reforged Tournament, Disconnects Lead To Unfair Defeat

1 Like

Hey there,

Lets go ahead and grab a winMTR so we can further investigate the problem. Here are the instructions:

  1. Download the tool from this page
  2. Enter the game IP into the “host” field. The IP address for our games are listed on the winMTR instructions page
  3. Start the test and play the affected game for at least 15 minutes. Ensure the problem happens while the winMTR tool is running.
  4. After recording the problem data, click “export text” and save the winMTR file in an easy to find location.
  5. Once you have that made, open the file. You’ll need to copy and paste the contents of the Text document into the post, and put four Tilde (~) marks above the winMTR. It’ll look like this:
WinMTR goes here

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

I’m so frustrated with this game! I played 3 games tonight, one of them was a 25 min long game. I pretty much had guaranteed wins, two times, one of the other teams’ members left saying “gg”. Then suddenly just a couple of seconds of lag and thrown out to the score screen… The third game my teammate left because he said the game was too laggy to play, really fun experience!

Makes me wonder, can a player trigger other players to disconnect? It’s uncanny that it usually happens when I’m about to win!

Here’s the MTR for 37.244.28.40:

|------------------------------------------------------------------------------------------|

|                                      WinMTR statistics                                   |

|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

|                                   kabel -   30 |  317 |  225 |    1 |    1 |    9 |    1 |

|  ip53a9b72d.static.kabel-deutschland.de -    1 |  680 |  679 |    7 |   16 |  195 |   11 |

|  ip5886eac9.static.kabel-deutschland.de -    0 |  684 |  684 |   11 |   16 |  172 |   18 |

|                            145.254.3.92 -    1 |  676 |  674 |   11 |   17 |  178 |   11 |

|                           145.254.2.195 -    3 |  617 |  600 |   18 |   27 |  222 |   24 |

|                           145.254.2.195 -    2 |  637 |  625 |   21 |   26 |  217 |   23 |

|           pr01.eqfr5.blizzardonline.net -    1 |  680 |  679 |   18 |   29 |  186 |   23 |

|              ae1-br01-eqfr5.as57976.net -    0 |  684 |  684 |   24 |   34 |  145 |   28 |

|         et-0-0-2-br01-eqam1.as57976.net -    1 |  666 |  662 |    0 |   40 | 2637 |   29 |

|                           137.221.78.81 -    0 |  684 |  684 |   25 |   35 |  167 |   37 |

|                           137.221.66.47 -    0 |  684 |  684 |   24 |   31 |  171 |   33 |

|                          185.60.114.171 -    1 |  680 |  679 |   25 |   34 |  288 |   30 |

|                            37.244.28.40 -    1 |  676 |  674 |   23 |   30 |  175 |   28 |

|________________________________________________|______|______|______|______|______|______|

   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Here’s the second one (37.244.28.140):

|------------------------------------------------------------------------------------------|

|                                      WinMTR statistics                                   |

|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

|                                   kabel -    9 |  510 |  466 |    1 |    2 |    9 |    1 |

|  ip53a9b72d.static.kabel-deutschland.de -    0 |  685 |  685 |    7 |   16 |  256 |   13 |

|  ip5886eac9.static.kabel-deutschland.de -    0 |  685 |  685 |   10 |   15 |   37 |   12 |

|                            145.254.3.92 -    0 |  685 |  685 |   10 |   17 |   60 |   14 |

|                           145.254.2.195 -   18 |  406 |  336 |   22 |   32 |  167 |   26 |

|                           145.254.2.195 -   18 |  406 |  336 |   19 |   30 |  168 |   26 |

|           pr01.eqfr5.blizzardonline.net -    0 |  685 |  685 |   21 |   29 |  102 |   71 |

|              ae1-br01-eqfr5.as57976.net -    1 |  678 |  676 |   25 |   35 |   94 |   28 |

|         et-0-0-2-br01-eqam1.as57976.net -    1 |  667 |  663 |    0 |   41 | 2916 |   29 |

|        et-0-0-35-pe02-eqam1.as57976.net -    0 |  685 |  685 |   26 |   35 |  161 |   33 |

|                           137.221.66.41 -    0 |  685 |  685 |   25 |   32 |   76 |   34 |

|                          185.60.114.147 -    0 |  685 |  685 |   23 |   31 |  289 |   30 |

|                           37.244.28.140 -    0 |  685 |  685 |   25 |   32 |   71 |   32 |

|________________________________________________|______|______|______|______|______|______|

   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Heya Qliver,

I’m noticing some network stability on this second hop here, after the data goes from your modem to your ISP’s network. It might be worth it to provide these tests to your ISP and let them know you’re noticing packet loss.

If they do a “ping” test and say everything is fine, request an escalation. A ping test isn’t actually designed for packet loss and the request would need to go to someone who has a better understanding of the issue. Provide them with the MTR if possible which displays the root issue in plain text.

I wish we had a more direct solution but I do hope the information helps. Cheers!

That is a round about answer that blizzard just gave. The issue is with the game itself and not the provider otherwise other people wouldn’t be having the same issues. I keep getting disconnected as well during in game play and I played several other games that does not have this issue. The classic game never had this issue and most likely you guys are trying to do a patch/hack to get the classic game to connect to the battle.net and hence the issue is happening. Most likely battle.net trying to determine if the connection is still active or something similar.

9 Likes

The new update patch has just come, but after a recently game i got the crash (desync) again after 5 minutes.

Looks like blizzard havent’t touched their hands on that :frowning:

3 Likes

I got the crash (desync) too

2 Likes

thats exactly wats happening to me i get a minute or so gameplay then just goes to scoreboard

3 Likes

i dont understand how to do this

Yesterday, I played about 10 games and none crash happened when i tried to used the classic graphics. But if I’d switched it to the Reforged graphic - it would have happened (it actually crashed 3-4 games the day before yesterday).

My friends and I, while playing in Versus mode, very frequently get dropped from the game, all at the same time,right when we are about to win. It happens when members of the other team start to leave the game, but sometimes we get kicked before any of the opposing players leave. Is this a hack, or an issue with the server? It happens in about half of the games that we play, and has really ruined multiplayer for us. Have you identified this as an issue, and is there a plan to address it? Thanks from a longtime Blizzard fan.

-Caesar

1 Like

Hey all,

Please be advised that we do not troubleshoot multiple users’ issues in one thread to prevent the thread from being derailed. If you’d like help for your individual issues, you want to create your own thread or contact support for help.