Collection portraits not unlocking

Finished whole human campaign on hard, no new icons, they appear grey in collection. If you wanted it to be just warcraft reforged specific, maybe put it in description?


I am having the same issue.

At first I thought it may have been because I used cheats here and there just to speed things along having already played through them all before, but even when I go back all the way through each one 100% legit, it still doesn’t unlock.

1 Like

I am having the same issue.

Same issue

Anyone find a fix for this yet? I am nearly done with the entire campaign, yet have 0 collection unlocks for the campaign.

1 Like

Just reporting that I have the same problem and I’m looking for the solution. I can’t believe that unlocking portraits is Reforged only feature.

to confirm what DonSrbin is saying a bit implicit;

Portraits only unlock if the missions are done in reforged graphics.
Playing in classic won’t unlock anything. Those are seperated campaigns. Progress in one is also not shared with the other.

I am having the same issue. However, my problem has two parts:
1- My orc campaign (prologue) does not progress from the second part (it is as if she only had parts 1 and 2 without going to 3 etc …).
2-Even though I ended the lordaeron campaign (human) in difficult difficulty I did not receive the icon.
I made them (as well as all the others) entirely in classic mode and none of them account for unlocking more campaigns and icons.
ps: game only in classic mode.

Same for me, progress in hard campaign is not unlocking parts needed to unclock portrait. I have only Classic version of warcraft. There is no information, if it is only for reforged. I would love to know if it is just Reforged content. And if it is, please add that information in the game. thank you

Indeed, portraits are only unlockable in the Reforged campaign.

Just finished Founding of Durotar campaign on hard difficulty, now I’ve beat all the campaigns on hard and it gave me all the portrait except for the last 4 (for completing whole game on hard 2 portraits and for completing bonus campaign 2 portraits).

That’s a known issue that’s on Bliz’s list.

The workaround is to start the 2nd mission and use the cheat code allyourbasearebelongtous.

That will register as completing the mission and award the portraits.

1 Like

I’m having the same issue with too. I completed the entire campaign on hard and finished the Bonus campaign and it didn’t unlock the portrait.

Any fix for this?

Portraits can only be unlocked by playing the Reforged campaign.

Worked for me! Thank you!
Had this issue from the second mission of the FT night elves campaign onward. Start the mission, use the cheat, and there you go.

1 Like

I have completed all campaigns on Story difficulty, in Reforged mode except Rexxar (doing that one now). Under Collection Portraits, some show completed but most that say complete on Story or Normal do not.

When I look at each Campaign, some of the boxes on the left of each Chapter have a Skull and some are empty. These DO correspond with what’s showing as completed.

What EXACTLY is needed for completion, other than the primary quest?

The cheat solution worked for me too. Thank you! I used it only on missions I completed without cheating and did not get portrait. Good workaround but I hope they fix this bug anyway.

OOOooookay people…
Most common problem over looked…
First… when you are on the main screen, where you select everything.
Bottom right corner is 3 lines.
Click it…
Option button appears
Click it…
at the bottom of the left side HUD you see
Classic <> Reforged…
Slide it to the right.
Than exit.
Don’t forget to save…

Problem solved.
Good Luck Have Fun.

I still have this issue.