Checkpoint Bug

So, twice now, I have encountered a save / crash error that seems to be related to the checkpoints. I’ve only played campaign so far. I am using the Mac client.

First time I encountered the issue was when playing Chapter 2 of the prologue. Reached a checkpoint, and instead of the notification disappearing completely, the brackets come back together and form a spinning square that sat in the center of the bottom of the screen for the remainder of the mission. Well into the mission, around the time when you rescue more troops, the game froze for several minutes, stopped responding, and I had to force-quit. I re-loaded the game and was forced to start the level over, meaning that the checkpoint I hit never took. And, when I went through and finished the level successfully, I noticed that a checkpoint never appeared that should have happened between the first brackets never disappearing and my game crashing (I think as you commit to fighting the human buildings in the south). This means that the bug and the brackets staying prevented another checkpoint from triggering and somehow prevented the checkpoint saves from taking at all.

Second time just happened when playing Blackrock & Roll. Hit the first checkpoint, noticed that the brackets had not cleared, so I tried to manually save to stop myself from losing progress like before. The game didn’t like that - froze, stopped responding, and I had to force quit. Seems like the checkpoint failing to clear causes some issue with all forms of saving.

Searched for “checkpoint” and didn’t see anything. All best

EDIT: I just encountered the bug a third time, again in Blackrock & Roll…This time I didn’t notice the spinning bracket square until my units were charging the Blademaster - not sure what checkpoint didn’t clear. (The last save I have is Blackrock & Roll (3) ). I was able to complete the mission, but the spinning save square stayed through the cut scene and then onto the Continue / Quit campaign screen. Then, when I tried to hit quit campaign, the game stopped responding, I had to force quit, etc. BUT, the game did seem to recognize that I made it to Jaina’s interlude and chapter 3…So at least the progress was not lost. Still seems to be a game-breaking/crashing bug lodged into this checkpoint thing.


I saw the same issue on the Mac client, at least before this Feb 6th patch. It seems to be a bug with the saving function because at those checkpoints the game autosaves. Like you it happened to me randomly at autosaves (checkpoints) and when I manually saved. It made me not want to save so that I didn’t have to force quit but then I could also lose a ton of progress on a level. I hope the new patch fixes it!

Same thing has happened to me like 5 times. The checkpoint little box comes up but fails to save and stays on the screen then once the level is complete I have to hard quit the game. Hope this gets fix soon

Has there been a fix on this? It is 2021 Sep now, the bug is still out there