Can't Launch Game. Starts up on a Black Screen and Cursor

Just bought the game last night and every time I try and launch the game it goes to a black screen and a cursor. I’ve tried looking to see if there was any anti Virus Software that would be preventing it from launching but I couldn’t find any installed on my computer.


Hey there DoubleD,

Thank you for taking the time to reach out with these details! To determine whether this might be caused by launching the game in fullscreen mode, try forcing the game to launch in windowed mode with these steps:

  1. Select Warcraft III on the app
  2. Next to the PLAY button, click Options and select Game Settings
  3. Under the Warcraft III section check the box for “Additional command line arguments”
  4. In the new box type in: -windowmode windowed
  5. Click Done

If the issue persists, let’s go ahead and have you post a ‘DxDiag’ so we can further investigate. Here are the instructions:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Once you have that made, open the file. You’ll need to copy and paste the contents of the Text document into the post, and put four Tilde (~) marks above the DXDiag. It’ll look like this:
DXDiag goes here

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

Tried setting it to windowed mode, but it still didn’t work. I updated the Main Post with a Link to the DxDiag Via Pastebin.

Hello! Same issue for me. Everytime I launch the game it is either too laggy, or it launches, but I cannot start the game at all. I tried campaign and multiplayer mode simply nothing happens. When I clicked onto ingame settings, there are nothing shown. Toggle between classic and regorged modes are greyed.

I’m also experiencing the black screen and cursor issue regardless of whether I launch the game in fullscreen or windowed mode.

Same issue.