Can't Join Custom Games

When I first installed warcraft 3 reforged everything was working great. A few days later I noticed I could no longer join custom games. Every time I try to join a custom game it says “downloading map” it sits at 0%, then I get into the screen where the game host is at then it automatically kicks me as soon as I join sending me back to the custom map game list. At first I thought the host was just kicking me out but then I realized it’s happening with EVERY custom game I try to join. Why is this happening? How can I fix this?

[Edit] I think the problem is something with not having the map downloaded first before I join. I tried right clicking on the game and clicking “download map” the same thing happens when I try that too. It says downloading map makes me join the game then get disconnected.

[Edit 2] I see that there is a “known issue” in the stickied posts on this support page.
[Known Technical Support Issues - Updated on Febuary 23, 2020]

However I tried navigating to the documents folder then the warcraft 3 folder then deleting the Maps folder. That did not fix it.

[Edit 3] I had just tested this and I joined a custom game with a official warcraft 3 map. When I joined everything works fine (with maps I already have downloaded).

However when joining a game that I don’t have the map on it will SAY it’s downloading the map but says 0% then skips the download process and it never actually downloads the map and the game thinks its downloaded already and it kicks because the map isn’t in the downloaded map folder.

So the problem is that the wc3 client is not downloading the map and skipping the download process. Any fix for this would help! Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.