Campaign missions not giving credit for Hard difficulty-FIX

Hello,
I wrote a ticket and was told to go and post my problem here.
I bought the game few days ago, and I have noticed, that since the Chapter four in the Orc campaign, the credit for completing the missions on Hard difficulty is not given to me. I have checked the profile icons collection menu, and it seems, that the missions do not count as completed on any difficulty for the purpose of icon awards. I have screenshots, but I did not found a way to include them in the post.
Have a nice day, PeaceWarrior

Same issue here. Even for Undead campaign on normal. Happens totally random but in general missions doesn’t count into avatar pictures from time to time.

Yeah, I checked the bug forum posts from the beginning, and the first report of this bug is from february 2020, so I guess Blizzard doesn’t really care about fixing it.
BUT, some people suggested that the problem might be with saving/loading the mission. Something like if you play the mission in one session, you get the credit for completing it, but if you save, come back later, load and complete the mission, you don’t get credit.
So far I know that I’ve saved / loaded mission 4-6, and I didn’t get the credit, then I read about loading, completed mission 7 in one session, and got the credit.
So, from my experience, the saving and loading really seems to be the problem. I will play the missions 4-6 again in one session, and then report here, if I got the credit for those already bugged missions, or not. Having to play it again sucks, but it would still be better than not having the option to get the award, since Blizzard doesn’t care.

-----EDIT-----
Well, problem “FIXED” - I tried to complete one of the missions again in one session, worked, and I got the award. Also, since I already completed the mission, I tried cheats on another one, also worked.
So, if you have any bugged mission like this, just play the mission again, write “allyourbasearebelongtous” in the chat, and you have the award.
Being awarded for completing the mission on Hard difficulty while cheating is god damn stupid and by far the biggest Reforged fail I’ve seen so far, but there is a little bit of good in everything bad I guess, so its useful in this situation.
Have a nice day, all of you who have the same problem I did.