Adding Shared Container Tech with Version 1.32.6

Starting with version 1.32.6, we’re transitioning Warcraft III to use the shared container technology that World of Warcraft and Overwatch already use. Having a shared container for Warcraft III means that we can have the different types of builds (currently retail and public test) use the same data directory.

In order to support this new technology, we’ll change the directory layout of the game. The root Warcraft III install directory will contain a Data folder, and one or more folders that represent the build types: _retail_ for the retail version and _ptr_ for the public test version. The Data folder will store data for all build types (reusing data when possible). The build type folders ( _retail_ , _ptr_ ) will act as the game root. For example, any file or folder that you previously placed in Warcraft III should now be placed in Warcraft III/_retail_ instead. If you have any files that you previously added to your install directory (not recommended), you will need to move those files to _retail_ or _ptr_ . With this new layout, you can have multiple build types installed side by side without disruption.

When installing a build, the user will still have the option to have separate installs of Retail and PTR if so desired. However, we recommend using the shared installed because it will overall use less disk space and will be quicker to install the Retail or PTR versions of the game.

There will be a phased transition to change to the new directory layout. You won’t be able to fully take advantage of this technology until both the 1.32.6 version of retail and the PTR have been released. The 1.32.6 PTR is aware of the new directory layout, but the current Retail version of the game is 1.32.5 and that version is not yet aware of the new directory layout.

Once the 1.32.6 Retail version is released, we highly recommend that you uninstall the 1.32.6 PTR version. Any future PTR or Retail releases after 1.32.6 will now be able to share the data directory if desired.


Thank you! This in depth discussion of formatting changes will work wonders for making sure the Retera Model Studio version that does some basic Reforged model editing can continue to function and show in-game textures while users are working on their model files.

After having to deduce lots of internal changes prior to Reforged with folders named MPQ inside of the data, then later folders named w3mod inside of the data, having a nice post like this should go a long way towards making it easy and efficient to keep user model editing tools running.


Actually, on top of that, I ran the latest version of the Retera Model Studio tool and and pointed the Warcraft III based stuff in my tool at the PTR using the Edit -> Preferences Window -> Warcraft Data and choosing Clear All and then choosing Add War3 Install Directory on the folder Warcraft III Public Test and the tool is running fine and loading model textures just fine. So, for anybody interested, it looks like the PTR is still going strong supporting fan-based tools without even updating the fan-based tools.


This is useful to not waste hdd space thanks I guess

1 Like

I hope that it wont accidentally break local files functionality(i use it to restore original dubbing)

sounds good

It’s probably way more useful for them. I think a lot of War3 updating has been on their backend to work more effectively and easily with their systems. We saw lots of work on this to prep War3 for reforged, looks like there is more to be done that we just aren’t aware of. Imo this largely explains the slower rate of development progress that community has been expecting. For me the worst part is wondering just what is Blizz up to, but this provides evidence that they still have lots of backend work they are doing. All missteps aside, I’m thankful for any bit of information that lets me know whats going on, the confusion is the worst part, and not knowing what the future holds. This points to “things will eventually be better”, which is better than not knowing at all. Just my take

1 Like

Makes sense, thx for the information

1.32.6 is now live and shared container technology still not working for me. My game still uses old non shared folder layout, even after full reinstall…

Same. Even uninstalling and reinstalling didn’t create the new file structure.

I don’t have this functionality either. Was it a part of 1.32.6 or not?

Bizzarrely it seems some of my friends didn’t get the new directory structure as part of the patch while some did, and now those of us who have the new directory structure are unable to use our installs with the NetEase client as it nolonger recognises the install in the retail directory.

Something is broken.

So maybe they introduced this functionality partially, only for some users? What region are you on?

Hey so have an terrain function which enables pathing of the terrain. I have this folder placed in the retail folder however it is no longer working. A recent patch (i beleive two before the last one messed everything up) i cant figure out how to get it to work.
Is anyone else having a similar problem?