StarEdit Deprecation in Patch 1.23.0


#21

Apparently I can’t include links in my post, so we get to step through the full website. Go to the Stormcoast Fortress website (use Google… no links allowed for me!), and on the left-hand nav bar under the “ScmDraft 2” section, click “Download”. Click on the first link on the page (“Newest alpha builds”). Scroll down just past the screenshots and download version 2019.07.09(W) – it’s just under the Donate button. Just open the .zip and copy all the files to a folder on your desktop and launch the “ScmDraft 2” file.

Note that I could not start the editor while SC:R was running – I was getting a “Cannot read data” error. Close SC:R and then launch the Default profile.


#22

Gosh i hope we could use diferent colors in the units while playing or even been able to select this option for singleplayer scenarios. But also i must say i tried to edit just the color of factions in some campaign maps like Enslavers and just had the same issue the great Ulrezaj has mentioned.


#23

What a great move by Blizzard… hmmm…

I knew StarEdit really well. SCMDraft had too many features for me to get my head around. But since a previous patch stopped StarEdit from working properly, I had started using SCMDraft 2.

But since this last patch, SCMDraft 2 can no longer find the StarCraft directory… even when I select it from the directory tree. I have no idea how to solve this.

If Blizzard are going to recommend 3-party content to their users, at least make sure it works properly!!


#24

I’m happy they’re using SCMDraft2 as the official editor, but it doesn’t allow you to select a directory with the new patch so I can’t actually use the editor now.


#25

NOOO! Why did you have to remove the official editor???


#26

ok, now that ive been useing it for a few hours strait i will say it is better. but its still an incovence to people who want to map edit casualy, and not go through a separate download.


#27

Got the same issue, and apparently its so uncommon that it’s nigh impossible to find a fix, tried the 64 bit and 32 bit versions and the directory of the launcher, but no luck

EDIT: did some digging and it seems the latest sc:r patch may have cause some issue with what the editor is looking for


#28

FOR SC:R 1.23 SUPPORT:

Make sure you are using the july 9th (or newer) version from here: Download list. You can unzip it and replace an existing install, or run it as a portable version from any folder.

If the starcraft path is not autodetected, configure the settings as follows: profile settings. Note: The autodetected path may be empty or display not found.
Set the custom path option and enter the path where you have starcraft installed. This is not the starcraft directory under my documents, most common case is “C:\program files (x86)\StarCraft”. It should include a “data”, “x86”, and “x86_64” folder among other files. Make sure to set the starcraft version to 1.23 or to autodetect in the profile settings. If your settings dialog looks like this: example settings, then you are still using an older incompatible version.

If you get an error message “Unable to access the CASC data!”, then the configuration is correct but the install is corrupt. You will need to scan/verify your installation using the bnet app.


#29

Thanks SinSanity, works perfectly now


#30

How about allowing us to download StarEdit as a stand alone program if we choose to continue using it. I could care less if Blizzard supports it, I just want to be able to continue making maps with a program I already know (No offense SinSanity but your program isn’t easy to use either)


#31

I’ve working StarEdit files, but I don’t know if I can share it here


#32

Just talked with Blizzard Support and there is “nothing they can do” to help us re-install the program. Pardon my French - this is B******t. You take away a program that came with the game we payed for! I feel like I’ve been robbed. When you buy something then someone takes it that’s stealing. An “Update” shouldn’t remove tools used with the game. If Blizzard has ANY honor they should at least ALLOW us to re-download the StarEdit program if we choose to do so.


(Matt Sherman) #33

We will be packaging up the last working version of StarEdit and deploying it publicly soon.


#34

Thank you. I’m very much relieved to hear that.


#35

Well, I’ve to admit I didn’t expected that


#36

Thank you so much!!!


#37

Good move. I do have to agreed with everyone. Or just add both editors and let people pick.


#38

Go to StormcastFortress - Scmdraft

go to download list

Download the latest version - top of the list. Simple as that


#39

I still have that issue


#40

From your original post I assume you are talking about Galaxy Edit (SC2) and not StarEdit. Assuming that’s correct, you’ll need to post in the SC2 forum, not this one. https://us.forums.blizzard.com/en/sc2/