Starcraft remastered not launching

Hey, so Ive uninstalled, reinstalled, repaired game files and all the usual fixes but I cannot get starcraft remastered to start. Just keep getting the same error message saying the game has broken files and needs to be repaired. Running on windows 11, any one got any ideas :sweat_smile:

1 Like

Hey Yamato99,

Are you using OneDrive? If so, it’s not compatible with SC. See this article to learn how to unsync your “Starcaft” folder (which is inside your “Documents” folder).

Hey thanks for the reply, I tried that there and its still not working :frowning:

Also doesn’t work for me. Still the same repair popup!

I have the same issue. The application encountered an unexpected error. I reinstalled, deleted all data, localdata, localappdata, cleared the bin, disabled onedrive, enabled onedrive again, unsynced docuemnts folder. deleted all blizzard games, reinstalled all. New graphics drivers. Optional windows updates. TO no avail.

Battle net also stole my Wc3, but I guess that is another story, I need to buy the new one now… anyway, it also didn’t launch anymore. now SC Remastered just won’t launch. I am going nuts! Please fix it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.