Starcraft Fails to Launch

Hello Tech Support Team,

Currently whenever I click ‘Play’ on Starcraft the blue button goes to ‘Playing Now’ but the game never actually launches.

  1. No AV software installed.
  2. Windows Firewall disabled.
  3. Reinstalled Starcraft
  4. Reinstalled Battle net
  5. Deleted Battle net Program Data
  6. Video drivers fully updated - 1070 Asus Strix

OS is Windows 10

No error codes as the game is not crashing. It simply won’t launch to begin with.

I would appreciate any assistance that can be provided to solve this issues. I’m unsure as to what changed because SC used to run fine on the exact same system. No major software changes have been made since it was working shy of installing additional games through Battle net and Steam.

Hey there Jinxix,

Usually the game failing to launch without an error message is due to an interfering program or permission problem. You’ve got a good start on troubleshooting done. The next thing is see if creating and switching to a new Administrator Account helps. This sets many settings to defaults and also helps with permission problems, so can be useful to do even if you’re using an admin account already.

If there’s still a problem, let’s check if any possible conflicts show in the Dxdiag. Could you generate(link with steps are here) and post one here please? Once you have it, just copy the contents of the text file created and paste it here between two ~~~ like so:

DxDiag Here

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

Hello! Testing the new user. In the meantime, please see the dxdiag below. :slight_smile: Need to put it into two posts due to character count limitations of the forum.

Edit: Created pastebin link due to forum character restrictions.

Edit2: Second user didn’t work. :frowning:

https://pastebin.com/CpJLDhMJ

Edit3: I should add that it seems to work sometimes completely randomly. At several points I thought it worked because I did something; turned off firewall, uninstalled AV, etc. But literally just now it worked for no reason. I didn’t do anything to make it work after trying to get it to load for several hours.

This has been the experience though;
Doesnt load
Try 5 different things
Finally works
Try the same thing that made it work last time
Doesnt work anyways lol

I’d recommend a permission for Brood War over disabling the firewall personally. Again Scan & Repair or uninstall/reinstall work wonders (though you’ve done it). I’d check if maybe it is launching in the background for some reason, I’d recommend keeping Task Manager up and see what happens to the exe once you click play. Check to see if video drivers are up to date as well as any possible windows or battlenet updates. Hope something helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.