ScmDraft2 not working after the patch


Hello after the last patch today I tried to run ScmDraft2 but when I press lunch an error appeared saying
“23:49:12.0930- Error::nable to initialize scmdraft’s game engine! (hr = 0x80070002) Launch with the -console command line for detailed error info.”

Edited: Check ScmDraft2 website they fixed the issue


Same with me! What’s happening?


Please fix the map editor, ASAP.


Hey all,

ScmDraft is not Blizzard’s. It’s a third party app, thus Bliz isn’t doing any development or support with it. You’ll have to contact the author, Sinsanity, if there are any issues.

The good news is that Sinsanity is pretty timely with keeping up with patches. If you bookmark their history, you’ll be able to see when updates to ScmDraft are released. From there, all you’d need to do is grab the newest version.

For reporting new issues, I suspect the Sinsanity is following these threads:

Plus, I suspect there’s a way to contact Sinsanity where you download ScmDraft (I’ve never used it so don’t quote me).

Missing mpq files for the SCMDRFT 2

They fixed the issue go to their website they fixed that.


The latest SC patch removed/renamed a required datafile, there is a updated build available here.


Hello Guys. My last contact with SC editor 20 years ago :smiley:
I installed Starcraft 1 free. Over directory, the exe in 32bit oder 64bit not start the game. Only via Blizzard Launcher the game start.
Okey, i try to install the editor “ScmDraft 2 v0.9.09” and start it.
Fail Error: no StarDat.mpq found. I have no MPQ files in my Starcraft Installation :frowning:

Question,… where is the original Editor for Starcraft 1 ? I want only check my old campaign, stored since 20 years.


StarEdit, the classic editor of StarCraft, has been removed from the game client with Patch 1.23.0. (Source)
Moreover, the editor is no longer supported by Blizzard. You can download the last functional version of StarEdit here: Public StarEdit download


Thank you Eredalis !!!
I checked my campaign. I’m so sad. 90% from my 25 missions are “defective files” :frowning:
90’s i worked for half year for this big campaign and nobody play it. we had no internet to share ^^
But all this time, the files was destroyed. very sad