SC Remastered - Error Creating New Character (macOS Catalina)

Hi, guys!

I’m getting the following error when trying to start a new game: “File error creating new character. Make sure there is enough disk space on the disk StarCraft is installed to, and that you have permission to write to that disk.”

I saw another topic with this issue, but the resolution didn’t work in my case.

How can I fix this?

Hey, duskblade! Just curious, what steps have you tried in another topic? The problem with this error is an issue with writing to the character folder, which should be under ~/Library/Application Support/Blizzard/StarCraft/Characters/ on MacOS. Have you tried checking that the Application support folder has the appropriate permissions? Does it help to try a new admin account?

1 Like

Hi there, Caterpepi!

I looked at the solutions in a similar thread, but those didn’t work for me.

Curiously, the ~/Library/Application Support/Blizzard/StarCraft/Characters/ folder didn’t even exist!

I created the folder, ran the Terminal code, and I modified the read/write access of the existing Battle.net folder , Blizzard, and Blizzard Entertainment folders and their sub-folders [using Get Info in Finder], but that didn’t work either. :disappointed:

Also, I’m on an admin account.

EDIT: I created a new admin account, and I was able to proceed there. Folders were also properly created. How can I replicate this on my main account?

Duskblade,

That indicates there’s some permission problems with your other admin account. You can try fixing your application support folder permissions, as Caterpepi mentioned. If that first link didn’t work out, there’s something major wrong with that account’s permissions and you’d want to work with Apple Support, or delete and recreate your main account. (Make sure to back up your files before doing that!)

1 Like

Hello, Drakuloth!

I’ve repaired permissions using macOS Recovery. No issues were found.

I noticed two things with my main admin account:

  • The ~/Library/Application Support/Blizzard/StarCraft/ file path is not created. [The one for SC2 shows, and that game works fine.]
  • Upon launching SC1, after the “Authenticating…” message, followed by the “Downloading Settings…” dialog, I get the “Download Failed.” message.

There has to be a way to get the game to create the appropriate folders and to get it to connect to Blizzard’s servers without having recreate my entire macOS account. :pensive:

Hey, duskblade! Thank you for giving those a try. It’s definitely concerning that the application support files aren’t being created on the main user account. Whatever is causing the file to not be created is likely part of the problem, so something with permission or something is blocking the creation/download of the file is what’s causing the problem here.

It’s a bit tricky to know exactly what’s causing the problem, but I’ll recommend what we can here.

If the problem does persist after all of this, it may be something a bit more advanced that the new admin account resets. You’ll want to contact Apple Support to see what might be going on with the permissions or the user profile.

Hi, Caterpepi!

Thanks for responding. Here’s a list of actions I’ve taken:

  • I turned off my firewall and reinstalled Battle.net and StarCraft.
  • I set read+write permissions in the game folder and repaired disk permissions via macOS recovery mode.
  • I’ve reinstalled Battle.net without any background applications/processes running and via macOS safe mode.
  • I’ve given Battle.net and StarCraft full disk access in Settings.

So far none of these have worked on my main macOS account, and I have tried those actions multiple times.

I fear that Apple Support would only redirect me to you, since this problem is app-specific, and does not involve the OS as a whole.

Are there any log files I could send to give you guys a clearer picture of the problem?

Thank you for the details and giving those a try, duskblade! I can’t make any guarantees, but you can open a ticket with our technical support team with the system files to see if there’s anything more we can suggest or double check if something may have been missed.

Though, with the New Admin account working, it does point to a user profile issue on the main account. Despite it being specific to StarCraft, there is something going on with the user profile on the main account causing issues with StarCraft from creating characters. User profile issues are outside of what we can assist with since there’s a lot of intricacies with what could be causing the issue.

1 Like

Hey duskblade,

To add on to what Caterpepi and Drakuloth mentioned, this should just be a matter of ensuring the folder and sub folder permissions are set to read and write correctly for the directory ..\Library\Application Support\Blizzard\Starcraft

Make sure that the lock icon is clicked to the unlocked position in order to preserve the changes once read and write is set.

If it looks set correctly you may try deleting the ..\Library\Application Support\Blizzard\Starcraft directory and have the game recreate it, then double check the permissions are set correctly.

We have not been able to reproduce this issue on a fresh macOS install with a new administrator account and a fresh install of the game, so it does seem like your permissions were changed at some point. The game client itself does not control permissions so it isn’t possible for it to have changed them or to correct broken permissions.

1 Like

EDIT:

Hi, everyone! :wave:

To anyone following this thread, I think I was able to get to the root of the problem! :sunglasses:

Yes, I was able to successfully resolve it on a new, dummy test account, but I was determined to play the game on my home account. So I did some tests.

I recreated my macOS home account twice (first through Migration Assistant, second through a fresh account with the same name). In both instances, the problem persisted.

But as they say, the third time’s the charm! :sparkles:

First, context: my home account’s folder name has dots/periods in it [to separate my initials]. And I think that’s what causes the read/write error.

The first StarCraft was created in an era when periods were forbidden characters in paths and file names, and I guess the game still hasn’t been patched to handle that.

I recreated my home folder without periods this time, and it worked! :partying_face:

So I guess this is something the team could look into? It’s an edge case, but I think it might be worth investigating to improve the playing experience.

[Original post below.]

Hello, Caterpepi and Jambrix!

Thank you very much for your help!

Yes, I have also mirrored the read+write permissions, using the new admin account as reference. Still, this fix didn’t work. :disappointed:

I appreciate that you tried to recreate the bug. I guess my options are to either play on the new admin account or to migrate my user account onto a fresh macOS install.

I have opened a ticket. Hopefully I am to resolve the issue without having to resort to either of the two solutions above.

Thanks for all your help!