Not able to edit maps successfully

Dear friends,

I’m using the ScmDraft 2 edior (latest stable version). At the moment, it’s not my goal to create brand new maps, but to just edit some of the maps that come along with the game (like “Jumble Rumble”) or can be downloaded from the internet.

I want to make some specific changes, for example make some units stronger, and disable some players from using some units.

It always seems to work well - I can make all the changes I wish, and then I can save the modified map under a new name and store it at its appropriate place. I can also start to play it. Yet, when I do, all those modifications I made are gone. Everything is just the way it used to be with the original, unmodified map.

Can someone tell me what mistake I make? Is it that one can only edit maps for multiplayer matches?

EDIT: It seems that when I change the terrain, these changes are saved. But I’m interested in changing the capabilities of players and units, not in changing the terrain.

Hello :wave:. What happens is that you’re playing under Melee/Free for All game type. All the aforementioned changes can only apply under Use Map Settings, for which you should add, for each player, a starting building (Command Center/Hatchery/Nexus) and 4 workers in the map, or you can preplace a different set of units to differentiate it from the standard game.
Use Map Settings requires at least one Computer Player, located in a different Force than the Humam Player. Changes are made in Map Properties and Forces, respectively.

Hello Savora,

thank you for your reply!
I tried to do things the way you suggest:

I placed the human player (player 1) into the “box” of the first “force” and player 2 (Computer) into the box of the 2nd “force”. (All the other players - which I all set to “unused” - where placed into the third box.)

I created a Command Center for both player 1 and 2 at their respective start locations (both player 1 and player 2 are Terran). I also gave them some some Firebats and some SCV units. And I gave each one an Academy.

And yet, nothing has changed. The Academy and the Firebats are not even displayed when I try to start the game…

Do you mean :thinking: you see :eyes: a starting Command Center with 4 SCVs, instead of the units preplaced by you? You have to select Use Map Settings as game type, because Melee and Free for All start with a headquarters and 4 workers for any race selected.
That’s the only thing I can think of.

Ah, thank you, this did the trick!
I did not think about this because when I tried to modify the maps with an old StarEdit version, it did not make any difference. But it does make a difference, now, with ScmDraft 2! :grinning:

However, Player 2 (Computer) does not seem to do anything but just remains totally passive. It does not move its SCVs and just seems to wait.

I guess I have to set some triggers to make it act normally, don’t I? Things are more complicated than I thought…

But can you perhaps tell me where the maps of the original campaigns? (You know, the first of the ten maps of the Terran campaign is called “Wasteland”.) I’d like to crate some maps based on these original maps if I can find them, and if I sould ever be able to use the editor in a meaningful way. :grin:

I forgot to mention :sweat_smile: about it. You have to set a trigger for Player 2. You can find trigger guides explaining what each trigger Condition and trigger Action :clapper: does.
Here’s a Mega folder :open_file_folder: with the campaign maps and .wav files:!39IxULSS!4VObGa6Teow7OVX1KHwC3w
If you take a look at these maps in the editor, you’ll find the AI triggers for Computer players.
I got the link from Pronogo’s wikidot:

There’s an extra mini campaign made by Blizzard, called Enslavers, in case you didn’t know. The maps are located in the folder named “campaign” in the default map directory. You should check that campaign as well. It’s a good showcase of the main features of Blizzard’s map editor.

@ Savora:

Thank you!
It seems I figured out how to run an AI script for the computer player using triggers.

I also found this site explaining several categories of “scripts” at classic battel net: “Exactly how do the custom AI scripts work?” (I cannot link to it directly). They mention:

  • Custom / Melee AIs
  • Campaign AIs
  • Insane AIs

But I’m not sure if it is always clear which AI script you can select in the editor belongs to which category of the aforementioned article.

I would like my AI adversary to behave just like it does in a standard melee match. Is there a special script for this purpose?
(I am going to try “Terran Custom Level”.)

Yes, you have to use Terran Custom Level.
If you want the AI to use Brood War tech then you have to select Expansion Terran Custom Level.

To post links you have to write them between a pair of grave accents, use `

@ Savora:

All right, thank you. I first had to set the script to run at some specific location before it worked, but now it seems to run as intended. For a newbie, it’s not really easy…

So custom level is like milee…?

If you want the AI to use Brood War tech then you have to select Expansion Terran Custom Level.

Will I get this technology too, in this case?

Custom Level scripts are indeed those you see in Melee games :video_game:.
Expansion Custom Level only works in Brood War, not in the original StarCraft. If you’re playing vanilla, you can’t use any Brood War script. Brood War tech is only available for the game expansion, independently of the script.

There are so many AI scripts which can be run. Just one example: “Terran 12 - Phoenix Town”. Is there any explanatin what these scripts mean and how one can use them?

Thak you for your help so far. :grinning:

Here is a folder with all the AI scripts:

In the scripts you’ll see the build orders and attacks. It is important that you check the build requests. If a build order cannot be fulfilled by the player running the script, the AI will break.

@ Savora:

Ah, thank you! That’s much stuff to have a closer look at!
Are you one of the develpers or how does it come you have so much useful and detailed information (if I may ask)?

I get the impression that the AI is attacking me a few times at the beginning, but then abstains from attacking me anyomre. This is true both for [Expansion] Custom Level and for Campaign Insane. And this also seems to be true when I do not pevent the AI from procducing some specific units or researching some specific technologies but leave it as it is.

If this is actually the case, is there any way to make sure the AI will attack me periodically, again and again?

I’m not a developer, but I’ve spent a lot of time making maps. Two years ago I didn’t even know the existence of ScmDraft. I created my own custom campaign last year, and I’m working on a new one.

This is true both for [Expansion] Custom Level and for Campaign Insane. And this also seems to be true when I do not pevent the AI from procducing some specific units or researching some specific technologies but leave it as it is.

I forgot to mention about upgrades and tech. These things, when disabled, also prevent the AI from working. I’m not sure what could be preventing the AI from attacking, in your case.
The AI needs enough resources, enough buildable terrain to properly setup its base, access to the required tech tree and to have the requested tech and upgrades available, then everything should be fine.

@ Savora:

My impressionis this: At the beginning, the AI seems to behave as it should. It attacks me, and it goes out to find and gather new ressources. But after some time, it ceases to do anything meaningful. It just goes on to gather some Vespene gas from depleted Vespene geysers, but that’s all. It won’t go anywhere new, even if there are many ressources (both minerals and Vespene gas) out there, and it will not attack me.

I did not block any upgrades or techs for the AI in some instances, but just modified some units of my own. (For example, when my AI adeversary was Protoss and I was Terran, I did not change anything with the Protoss settings, but just made Terran airforce more powerful.)
Maybe AI players won’t attack when they “think” the human player is more powerful).

Or maybe it has to do something with the fact that I am using large maps which are designed for multiple users but only have one or two Ai players on them? Perhaps I should try with smaller maps (or more players on them, alternatively)?

Protoss Insane AI became bugged after Remastered, and some other Insane AI scripts as well might be affected by Remastered. I don’t know exactly the reason why these script are no longer working correctly, though.
But I’m sure it’s not the map size, and neither the player’s advantage in the game.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.