Map editor not saving anymore

I’m just using StarEdit, the one that comes with StarCraft. I did search about scmdraft. Would you recommend to use that instead? Do you know where to download it?


I’d recomment it, but its up to you. The errors you have with staredit are very unusual so I cannot say whether it will help. Perhaps you are trying to save to a dir without write access.

News post for the latest official release is here:

And newest nightlies are here:
1 Like

Thanks so much for these. I downloaded scmDraft 2 and will give it a try.

I am having the exact same issue. I was advised from an employee to come here. I am using StarEdit and I too am unable to save any map(s) that I create. Whenever I click on save nothing happens, it just doesn’t save. The map is always labeled untitled for me as well. The program’s save function just doesn’t seem to work for me either.

Start downloading scmdraft 2. It works pretty fine! :slight_smile:

ScmDraft is a great choice. Given that there are superior third-party alternatives, we do not actively support StarEdit any more, and in future releases we will no longer ship it.


Oh I had no idea StarEdit wasn’t supported anymore. I suppose I will download ScmDraft then. Thank you for letting us know.

1 Like

Thank you for clarifying that you no longer support StarEdit. I’ll just go with scmdraft 2 moving forward.

My girlfriend and I were having the same issue. I found a fix. I still have my old installation CDs from 1998 and the “.LOC” files were on it. What you need to do is Copy the SEditDEU.loc, SEditENU.loc, SEditESP.loc, SEditFRA.loc, SEditITA.loc, SEditPTB.loc and put them in your Starcraft folder. I’m not sure if this is an official fix, but it worked for us. Happy editing!

1 Like

Heya Starcraft Developers,
I also experienced this issue today when I was trying to save a new map that I’m working on (using StarEdit). This issue appears when you are trying to switch the map from ‘Starcraft Original to Brood War only’, meaning from SCM file to a SCX file. I could create and save my map without any issues until I was putting in some new ramps (from the update patch earlier). Normally the program would tell me that I’m using an only (Brood War doodad) and the map will not run with the original game and resave it. But that window never shows up and the program is telling me to save my new changes before closing the program.
After I tried to save my map for the 10th time I clicked on disband. I opened my map again and it was back in the original state without the Brood War Ramps.
P.S. Also some of the latest patch releases has screw up the triggers. I need to redo all my triggers in one of my campaign maps and part of that I cant use them. I need to delete them and recreate them again.
Considering this is your game so you guys at Blizzard (Activision) would have the StarEdit in a full and complete version. Add everything that the SCMDraft has and there is no point using that program anymore. I really liked when you guys added the new ramps and I thought from there, more things will come. But now after your response you guys don’t even care about fixing this one.
Hopefully my facts will help you figure this problem out and fix it in some patch.

Thanks in advance.
/PlasterNET (Starcraft Remastered User and 20 years Starcraft Enthusiast/Player)

1 Like

Just out of curiosity - why do you prefer staredit updated with all the scmdraft features, instead of using scmdraft?

Hi Sinsanity.
My first personal reason is that I don’t like when game companies abandon their own product (with their response above) and rely on third-party developers/programs. When they could easily make the time and update their own program at a similar state.
Second: I like to just load StarEdit and start creating a map and not worrying about all the “tools” that you have to choose from. I’m not slightly against it but in my own opinion, I believe that Blizzard can easily take the SCMdraft program and make it for them own and much more easier to navigate thru.
Third: I don’t like their respond when they are not even investigating the issue and just calling it a quick. Well in my world thats not acceptable.
Fourth and final reason: They only real thing for them at this moment is to receive new maps for the map pool in seasons and update the season further. The Developers can spend their time to make a StarEdit 2 Version for all their beloved fans and users that still loves Starcraft 1 and enjoy Starcraft 2.
They could make StarEdit 2 launch and… -Here folks, we have made 10 new maps for multiplayer action. Enjoy. Simple like that. I dont like to settle (thats in my nature) and accept everything they write when I know they could do better at that company for the player base.



Ok, I can understand you wanting an official editor. If you had said staredit in its current state works better / has a better UI / etc, that is something I could work on.

I’m fairly sure they are looking at what broke. However if you look at the list of 2019 priorities, they do have a lot more planned than just updating the mappool.

Same issue. I really would like blizzard to fix it.


In all honesty, this is disgusting that they would spend the time to BREAK their own editor as the program has endured without any issues for YEARS without any problem. Its not as if this game is or SHOULD be constantly patched forcing extra effort to muck with the editor.

This is just more proof that Blizzard as a dev company is dead to the consumer and only a hollow shell of their former self.


Well, default editor was really bad and no serious map maker used it, although I understand, you could do basics. Your only choice is to use SCMDraft because it’s really powerful.

Hope Blizz will implement and ship it with Remastered in future. Maybe they’ll buy it off from maker.

1 Like

Since Customer Support Agent Caterpepi has closed my thread (i.e. my BUG report), I’ll try to reply here as he suggested (!).

First, I’m quite shocked to read about this (somehow cold-acting) comment from the devs that StarEdit got a headshot just like that. :disappointed: But, that’s another story…

Now, what we really like to know is how you developers will handle this reported bug (Load Next Level Trigger Doesn’t Work Anymore), because all of YOUR campaigns (Precursor Campaign; Enslavers - Schezars Scavengers; Enslavers - Dark Venegance) are affected by this (newly created) bug, too. Only to say “we will not support StarEdit anymore” is simply not enough kind of statement.

No editor is able to handle this bug, because it is mainly an ingame problem. So could you please answer in a clean and straight manner if you developers aware of this particular issue and how are your overall future plans look to fill this gap that StarEdit has left.

Thank you in advance!

Apparently shutting down StarEdit support also means shutting down custom content support, so why bother.

1 Like

That agent needs to be fired because your question wasn’t even about StarEdit but the game itself! Instead of helping they shutting down threads. This way devs won’t have chance seeing the issues.

Load next trigger bug is definitely editor independent - it may have to do with whether the map is in the starcraft directory or in my documents\starcraft\maps , have you tried both locations?