[Main Thread] Mac OS - Can't Connect to Battle.net & other issues after 1.23.5 update

it does not. This incompetent customer manager. Ruining the whole game

1 Like

Obligated to ruin the game with a patch every week, thats the most stupid way to ruin blizzard. Not mentioning you are not able even to write back when I make a simple question.

1 Like

Im getting really frustrated… it’s still not working.

My Battle-net/Starcraft screen button says “update” not “Play” when I go to update it goes 90% of the way through and cycles though popping up an error code that reads “Looks like there is a problem, give us a few minutes to finish the scan” then it repeats the failed process. I need some help here fellas…

StarCraft anthology crashing, can’t get past loading screen. I have a MacBook Pro 2017 i7 and I just updated to high Sierra but still crashing. It will just pin wheel and I have to do a hard restart of the computer every time because it locks my whole computer up. Please help, thank you.

1 Like

Same. Freezes on start up, and I have to do a hard shut down whenever I try running SCR.

Was hoping the latest update would help, but still unplayable. Was hoping to play with my roommate (in the same space) before he moves out of state… not sure that will happen.

Running High Sierra on a specced out mid 2017 iMac. Used to run the game beautifully.

1 Like

Could you please send an email to ramius.forum@blizzard.com so we can try to reproduce the issue internally and have it investigated?

1 Like

Hey Grant

Did Blizzard regression test this patch for MacOS before pushing to prod?

It’s just sort of embarrassing for Blizzard to have an issue like this where every MacOS player simultaneously goes down after a patch.

2 Likes

Hi Grant, was that by chance directed at me? I’m happy to help if I can.

Please consider supporting High Sierra for a long time. :slight_smile:

1 Like

Yes, anyone who is having problems due to 1.23.5 - freezing, crashing, etc. please reach out to us directly so we can try to reproduce the issues internally.

1 Like

Awesome, I sent off an email with a promise to provide a more detailed description if necessary. Hopefully the problem can be discovered. :slight_smile:

Since the 1.23.5.8607 update, mine now seems to work (haven’t played yet, but the menus function as they should and the Battle.net servers appear again).

Re: reply above about High Sierra and EOL: I think this is probably right. Apple’s planned obsolescence of their products will soon reach High Sierra, where I’m officially maxed-out. It seems funny how people will at some point probably not be able to play a game that came out 20+ years ago because they have a 4-year old version of an operating system.

1 Like

macOS Catalina
Version 10.15.6
Install StarCraft2 on 7.30.2020 11pm EST.
Tried 2v2 but the game dropped me three times after only 5 minutes of gameplay.
Error “Attempting to Connect”.
I am hardwired to my Router, 1000MB internet speed.

yo havasu its goon, can i add you man? whats your # ? i added havasu#35117 i didnt know if that was you or not

Same here, I updated both the Battle.net and Hearthstone apps, and after that I was never able to log in to my Battle.net account on my mac Mini, thus rendering Hearthstone unplayable. Funny that I was still able to play Diablo 3 accessing it directly, rather than through the Battle.net app.

So the real issue is that Battle.net cannot go online, and as such shows “Error code: BLZBNTBNA000003E8”. In other words, the Battle.net app does open, but it simply cannot connect.

I also opened a ticket and exposed the issue. I followed all of their suggestions, but nothing work, yet they would continue to claim things like that my Internet connection was having issues, which was not the case, as my iPhone was still able to connect and run Hearthstone without issues under my same Internet service. They also wanted to blame it on me not updating my operating system, yet setup still meets the minimum requirements:

Mac

Minimum Requirements Recommended Specifications
Operating System OS X® 10.12 (latest version) macOS® 10.13 (latest version)
Processor Intel® Core™ 2 Duo Intel® Core™ i3 or better
Video NVIDIA® GeForce® 8600M GT or ATI™ Radeon™ HD 2600 Pro NVIDIA® GeForce® GT 650M or ATI™ Radeon™ HD 5670 or better
Memory 2 GB RAM 4 GB RAM
Storage 3 GB available HD space
Internet Broadband Internet connection
Input Keyboard and mouse, or touchscreen
Resolution 1024 x 768 minimum display resolution

Here are the specs as to avoid the Customer Support representative asking for them:

Mac mini (Late 2012)
Processor 2.5 GHz Intel Core i5
Memory 16 GB 1600 MHz DDR3
Graphics Intel HD Graphics 4000 1536 MB

P.S. - At least I’ve been more productive with my life ever since I couldn’t log in to Battle.net .

I’m still experiencing the issue where the game freezes on start up and gets stuck on the title screen.

I’m using Mac Os High Sierra 10.13.6 with starcraft Patch 1.23.6.8974.

My Computer is an iMac with Radeon 580 Graphics Card.

same issue. game crashes unexpectedly on the title screen. this has been an issue since july and has not been fixed yet.
device: mac os high sierra 10.13.6
processor: imac 3ghz intel core i5
memory: 8gb 2400 mhz ddr4
graphics: radeon pro 555 2048 mb

SC1 game hangs on brood war splash screen

2017 iMac - High Sierra 10.13.6
processor: imac 3ghz intel core i5
memory: 8gb 2400 mhz ddr4
graphics: radeon pro 555 2048 mb

On Mac OS 10.13.6 myself. Was having issues connecting to Battle.NET , application was hanging at login screen with weird error not making the connection.

Restarted the mac. Ran the blizzard agent, that application updated the launcher and then it worked…

After playing this game for a few years (off and on), the OP’s issue started for me yesterday. Hoping for some assistance…