Game Will not open on Launch

I have been trying everything I can think of to get this game to open when I click Launch game,

Deleted all Blizzard folders from my computer.
Uninstalled and reinstalled the blizzard ap.
Uninstalled and reinstalled the game again.
No other programs open when I launch the game that have an overlapping interface (discord / one drive/ Steam etc…)
Walk through the help topic guide steps as following
To fix any incompatibilities causing this problem, try the following steps:

  1. [Update your drivers and operating system]

  2. [Update or temporarily uninstall any security programs]

  3. [Delete the Tools folder]

  4. Run the [repair tool](

  5. [Close all other applications]

Updated my drivers
Updated my computer
Deleted all Blizzard folders from my computer.
Uninstalled and reinstalled the blizzard ap.
Make sure the blizzard app is updated.

Forced Crash of every program running on my computer that is not a system thingy to try to get the game to run

upon clicking the play button.
Get the following error
Get the following error on SC2

Hit my head into a wall

Processor AMD Ryzen 5 3400G with Radeon Vega Graphics, 3700 Mhz, 4 Core(s), 8 Logical Processor(s)
Name AMD Radeon™ RX Vega 11 Graphics
Installed Physical Memory (RAM) 12.0 GB



Seems the game is running into issues reading a required cache file. Can you please try the following steps:

  1. aswhook.dll is related to Avast or AVG can you please setup either program to exclude the Desktop app and Starcraft: Remasted from all scans.

  2. At your desktop press (Windows key + R) and type in: %appdata%
    Press the Enter key. Within the folder that appears open the Blizzard folder, delete the StarCraft folder at this location. Close the folder.

Retest the game. Thank you!

Thank you.

I am having the exact same issue. I’ve tried everything, including deleting the starcraft folder with in blizzard folder in appdata. Game still fails to launch

1 Like

Hey there ChanceyBoy,

I looked into any crashes that may be related to this and suspect OneDrive is to blame. It can sync folders and cause the game to not launch. Please try turning off syncing for the Starcraft folder in your Documents. If that doesn’t help, disable it for the entire Documents folder and then test. Microsoft has information on doing this here.

I am also having this issue and Iv tried everything suggested here and it still will not open.


I Signed into one drive and it started to work as soon as I did that, I have no idea but that’s the answer in my case.

Everything is good to go now.

Yep that did it, turned off sync in onedrive and it fired right up. Thanks!

Thanks Cubanboy31. Your solution solved my problem with crashes on launch!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.