FPS Cap won't work

Hello. I bought today the Starcraft Remastered.
But, it seems that the FPS CAP isn’t working, and the gaming runs at more than 300 FPS.
With that, my GPU stays stuck at 100% of use without need.
I’m using Windows 11.
The FPS cap only work in windowed mode.
Is there anything else that I should do to fix this?
Thanks!!

FPS cap work fine for me. (Windows 11 22H2/ Full screen mode)
Try editing CSettings.json in Documents/StarCraft folder. (use notepad)
"FPSLimitEnabled": True & "FPSLimit": 144 or 240 etc.

Hi! Try changing the renderer engine, that might help. Here’s a bit of a of a guide on that:

To add a switch to Starcraft take the next steps:

  1. Open Bnet App
  2. Go to Settings
  3. Go to Game Settings
  4. Tick Additional command line arguments
  5. Paste in a switch, for example paste in --renderer=legacy or --renderer=ogl. If those won’t work, try some others.
  6. Hit Done
  7. Check if the FPS cap works
1 Like

This worked. I set --renderer=dx12 and the framecap worked!

Thank you

You are welcome! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.