Click Play & Nothing Happens

I am trying to play SC1. I am on the battle.net app and all my other games play fine. I try to play SC1 and click play and then the blue bar says it is launching the game and now playing and then nothing happens. I have tried everything possible such as:

  1. deleting battle.net and then reinstalling
  2. uninstalling the game and then reinstalling the game
  3. trying to run it as admin
  4. trying to run battle.net as admin

Why is this not launching?

1 Like

Hey there Skandalus,

Thanks for reaching out on this. It sounds like something may be blocking the game’s connection specifically. Lets try this:

  1. Troubleshooting security applications.
  2. Troubleshooting firewall configuration.
  3. Disabling background applications.

Let us know how things go. Cheers!

Hey,

I do not have any security applications besides Windows Defender and tried disabling everything. Starcraft remastered is being allowed through both Private and public networks and I already disabled all non Microsoft Services. I also reset the firewall to just be sure. I just intalled SC1 on a very similar PC except this only uses intel graphics and the game actually loaded, so it is isolated to this PC so far, but why? The only difference between them mostly is this one has a 1080TI. Is there some kind of distributable or Direct X item I am missing?

same situation ! @skandalus do u join successful ??? i cant join in as u ask !

I am having the same issue. Windows 10 with a 1080

Star craft remastered will not launch when I press play. I have tried all the options to fix this issue on your site.

I have went as far as reformatting my pc back to factory settings, updating all drivers, reinstalled the game. Same issue.

The game ran just fine up until the latest patch of the game. My pc specs are well beyond the necessary required specs needed to run the game in every way.

Same here. Everything was fine one day. The next, starcraft wont launch and there was not an update or anything altered from my end.

It has been doing this on and off since its release! Tickets dont get fixed either.

I have been trying to play starcraft remastered for over 6 month with zero help from a blizzard employee. I am starting to wonder if you simply stopped caring about your customers or what. I have put in several tickets about my issue, the only response I have had was a workaround for Starcraft 2. Starcraft 2 works just fine on my pc but remastered WILL NOT LAUNCH. Honestly I am done paying for any games or my WOW sub until I get this game working. SC worked just fine until a update 6 months ago…

I own every single game blizzard has ever launched, the lack of support the players are receiving is unacceptable

Same issue here. Starcraft crashes on launch with 1080Ti on Windows 10. I’ve reinstalled the game at least 5 times now, reinstalled Battle.net launcher 3 times, and deleted cache files. Nothing seems to work.

All other games launch just fine.

Same here and a trash default response from blizzard. So glad i decided to reinstall battle net. At least i know not to spend any money with them.

Same issue SC 1 used to work and now no longer works i dotn even see the SC1 executable come up in taskmanager

Count me in too. Same issue. Click Play, the button says ‘launching’ then up pops window with application encountered an unexpected error with this code: 2AA0792B-A323-46DE-B372-A6A12A715FE7. Sigh

I did have this problem with both Starcraft 1 and 2. I fixed it with 2 by resetting in-game settings. This option can be found by looking at the settings and game settings page in the BattleNet client. You should see it under the option to play the game in 32 bit.

However, this option does not appear for Starcraft 1.