Bonus Skin, don't see them anymore , FIXED!

Hello, i can’t use the pre-order skins anymore for some reason, tried to untick and tick the box back in the menues, nothing. closed SC, restarted, nothing… why can’t i see them anymore? i also tried to use F5 to switch from remastered to original, and back to remastered and still nothing.
how can i enable them again?

EDIT : i didn’t realize that it was changed under “collection” , it’s working again! :3

1 Like

What do you mean by under “collection” I lost mine as well

On launch of the game, in the bottom left corner, you should see “Collections” as an option. Make sure to check that “All Collections” is selected on the drop down menu at the top. You should see the Pre-Order Skins under Unit & Structure Skins.

This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.