Blurry buildings/units on Intel UHD 600 series graphics cards

Greetings,

I have this problem with the remastered graphics since i installed the game on my new laptop (Intel UHD Graphics 620). Whenever i zoom in on the map, all the units, buildings etc. look blurry: their edges aren’t sharp enough. That’s quite strange and honestly unexpected since my old laptop (Intel HD Graphics 4000) had no trouble rendering those graphics in full detail. I also had some graphical glitches like black horizontal lines on the minimap, but the latest major update has got rid of them.

Before you ask, the graphic drivers for this laptop aren’t generic and i have already updated them. plus the fact that the latest update has fixed some problems tells me that perhaps the problem is on the game’s end. I was wondering if you guys have any idea why this problem might occur, and whether following updates might fix it.

I’m also attaching the DxDiag:
pastebin(dot)com/sbvRikv9

Hey, Dududil! Thank you for the details and DxDiag files! There is another hotfix that is planning to address some issues with performance loss and the Graphics API, DirectX 9. Hopefully, this might improve some of the graphical issues.

Checking out the DxDiag file, there isn’t much here that points to the graphical issues. The drivers are fairly up to date, and so is Windows. Most of the errors are with window services and those just look like hiccups, but nothing graphically relevant.

Just to cross everything off the list, could you provide a screenshot of what’s happening and a screenshot of the HWMonitor while running the game?. Use an image sharing website like imgur and paste the URL between two ` (~ key) like so:

`Link Here`
1 Like

Greetings Caterpepi,

Thank you for looking into this issue. As you can see in the screenshots (i hope i’ve managed to upload them properly), the edges of the buildings are jagged, and marines and SCVs look blurry with poor resolution. Like i said i know what they’re supposed to look like because my old laptop did a pretty good job of it.

Here’s the in-game screenshot:
https://imgur.com/a/YNaulyM
https://imgur.com/a/1mF2DBB

Here’s the HWMonitor Screenshot:
https://imgur.com/xXAqmWc

Happy to provide you with additional info.

Hey, Dududil! Thank you for both of those! I do see that the units and buildings are quite jagged and pixelated. It looks like a mixture of Classic+HD graphics in the screenshots. Do you see any difference in Windowed mode by chance if you’re in fullscreen?

The HWMonitor, was this taken with the game running? The clock speed values look a bit too low if it was. It’s around 600-700Mhz. If the game was running while the screenshot was taken, it may be worth checking the BIOS settings for Intel Speedstep since this can cause the clock speeds to be pretty low. The processor looks to be getting a bit warm too, which might cause throttling issues. These might be what’s impacting the issue since it’s using the Intel Graphics as well. Could you provide the Intel HD 620 details of the HWMonitor?

1 Like

Hey Caterpepi,

Here’s the screenshot of the HWmonitor during an in-game battle:
https://imgur.com/a/Keg8eqK

I hope the information you’re looking for is here.
I’ve tried the windowed mode but it made no difference whatsoever. Is there any additional or detailed info that i can provide for you?

I wonder if this is at all related to the terrain flickering bug I see with HD graphics? Intel Iris Pro 5200. Up to date drivers. For me this issue started with the graphics backend update when it was pulled over from the PTR.

1 Like

It might have something to do with it. The update following the PTR solved some graphical problems for me. The answer from the Blizzard people has got me to think that perhaps it has to do with how certain components divert and use the power. I wish i could get some solution or additional info about the issue.[

Dududil,

I checked out your latest screenshot and this actually all looks fine. I’m almost wondering if this is a difference in graphical settings. Can you reset both your video driver settings and game settings to default for me? Be especially aware of any anti aliasing settings on your GPU settings, and mess with the SD Graphics Filter slider to see if it improves between Sharp and Filtered. It’s possible what we think looks “Better” just looks “Incorrect” to you with too much smoothing.

1 Like

Hey Drakuloth,

I’ve tried resetting both video driver and in-game video settings, but nothing has changed. I turned AA as well as some other video processing filter on and off, but the results remain the same. The SD Graphics Filter doesn’t affect the HD graphics at all, there’s no improvement or change to speak of. It’s really curious that i get different visual results on this particular laptop. I’m about to give up honestly, but thank you very much for your help! Please let me know if i can mess with any other setting that could work for me.

I’d figured as much with the slider, but was curious if it was malfunctioning. Try as I might I haven’t been able to get my client to look like yours either, so I was nearly sure a graphics driver setting would be the answer. That said, I’m running on a Nvidia dedicated graphics card, so my drivers may be running things differently than yours.

The UI itself has the correct level of sharpness but the models and terrain especially look like they’re being smoothed to an odd degree. I’m curious if other people with Intel HD 600 series cards are also having this problem, so I’ve changed the title to see if anyone else might come and chime in.