Failed to log in to Blizzard with AUTH_BGS_CLIENT_RESPONSE_ERROR


#1

I got the recent patch, and I can no longer log in from the Editor. I haven’t published anything, and I can still log in to the website, launcher, and game so it’s not a forgotten password.

Is anyone else having this “Failed to log in to Blizzard (AUTH_BGS_CLIENT_RESPONSE_ERROR)” warning MessageBox and a failure to move past the Log In window?


#2

You can try the following:-

  1. When opening up the Editor, there will be a text which prompts up asking whether you would like to log in. Click -> no. (This happens when you are using other dependencies apart from the standard dependencies). When another text message prompts up asking to proceed anyway, click -> yes.

  2. Next, select File -> Manage Published.

  3. Then, select your Region -> Authentication_US_Region (for example) and Log In.

Hope that this solves your issue.


#3

It does! Thank you so much


#4

I wasn’t prompted when I started the editor, only when I tried to open something I had recently played. I tried going to “Manage Published” and follow those instructions from another post, but I didn’t get any Region options. FWIW, this is the first thing I’ve worked on, so I haven’t published anything; I don’t know if that makes a difference.

Update: It updated again and now there’s an empty drop-down, and I was able to select my region there. Thanks!!!


#5

@NotNuke I had that same problem and after reading this post was able to fix it I feel kinda blind for not seeing it before.