"Your rendering device has been lost", since new patch

I’ve had this error come up 5 times in just as many hours, this has only happened since the last patch. Nothing in the thread about it is going on. I have almost 400 hours in this game and have never seen this error before. I have an i5 and GTX 1060 max-q, my gpu is not overclocked, not nearly overheating (running at 60c on load). Reinstalled the game. Updated my graphics driver.


Did you check this thread? "Your Rendering Device Has Been Lost"

Not only did I check that thread, I listed off the majority of the reasons they give not being the case for my computer, saying “Nothing in the thread about it is going on”, that is my bad though, I guess that sentence is a little vague… Also, it’s only happened since this patch.

1 Like

Sounds like coincidence. Let’s look at a dxdiag. Post it between ` marks

like this or use pastebin and give us the end of the link (preferred)

Sorry, but 350+ hours of this never happening, then a patch happens and the error happens 5 times within as many hours, that does not sound coincidental at all.
Gimme a minute or two to save the info files.

1 Like

Applications update in the background all the time causing issues like this, and since the majority of players are not experiencing this issue, it’s most likely something happening on your PC.

1 Like

The only thing I haven’t tried is uninstalling and reinstalling. I know patches can be interfered with by other programs, as windows files intermingle. For a bit of background, I do have 4 years in A+ computer repair/network training.

The DXDiag is too many characters to post.

Use pastebin and just give the hash on the end of the link.

And post must be more than 20 chars so dooooo doooooo dooooooooo. Lol.

Windows Error Reporting:
+++ WER0 +++:
Fault bucket , type 0
Event Name: AppHangTransient

We do see that the app is crashing, so I would take a look at the Windows Event Manager and see if there are any critical events happening around the same time, especially since you’re also showing some CPU errors in your log. Like this one:

+++ WER1 +++:
Fault bucket , type 0
Event Name: LiveKernelEvent

Problem signature:
P1: Razer Synapse Service Process.exe
P3: 5b7b34a0

Also, not sure if you’re still using any Razer devices, but the software is still on your computer and causing an issue.

Some other thoughts: Are you plugging in any external monitors or tablets? Sometimes these can cause an issue. I also think your GPU drivers are out of date… how are you updating them? Directly from nVidia or through Windows?

I would also try the reinstall. It can’t hurt.

I just updated drivers through Nvidia Experience 2 days ago, not out of date. Had the error happen 3 or 4 times before update, once or twice after. I don’t really use my razer hardware (I don’t have a desk, I use a dinner tray and a clip on mouse pad with Logitech G602), so I didn’t think about that. I’ll go into the startup programs and take that out. I do plug in a tv at times, but I don’t think I had it plugged in last night, and I definitely had my display set to PC only.

There are some other posts that say plugging in a TV specifically causes this problem. So this might be it.

Went into the Event Viewer, there are errors from Razer and from SupportAssistAgent, which I’m pretty sure is Dell Support Assist, which is Dell’s driver program. The error for that just says “An exception occurred in session change of service start: Object reference not set to an instance of an object.”. Honestly, I don’t remember the times I was playing, to remember if that error lines up with my playtime. There was only one Razer error in the past 24 hours, and it did line up with some playtime, but definitely didn’t line up with both times the error was thrown at me, last night. Looking seriously back in the log, SupportAssistAgent errors seem to be thrown all the way back to when I installed OW…

There are tons of drivers installed for whatever the Dell agent is… I noticed the list of them in your dxdiag. When I looked it up, it’s supposedly something that “helps your hardware communicate with your OS.” This sounds like corporate garbage for “we try to use our proprietary software to ‘optimize’ your experience.” I’d try to scrap as much bloatware as possible.

1 Like

It’s kinda crazy that a game like this has a literal game breaking error that can be caused by so many different things… I don’t think that uninstalling Dell Agent will uninstall all of the drivers for it… I’m gonna download Auslogics Boostspeed because their uninstaller allows you to uninstall any associated files.

So, I deleted all of the Dell support programs, and played around a bit. Played for about an hour, didn’t get the error. But I was in the ptr, so I’ll update later when I play live. And I haven’t reinstalled the game.

Hyo Lamp, i am not a support from Blizzard, but i’ve made a guide that hopefully can help you.

Check it out, and let me know if it worked for you ^-^/

This error is totally randomly, I rollback my gpu drivers and everything was alright, but after some overwatch updates its start again. I believe what is some kind overwatch problem, not a hardware, because to many people have this problem and its just only on overwatch.

For me, it does seem to be temperature based? But it triggers at like 72c

Hey Lamp ^-^

I’ve posted a guide that I’ve personally made some time ago, because I’ve been personally struggling with this problem for a while, hope it helps you ^-^