Your rendering device has been lost! Application closing!

I have tried in the forum for this problem, and it hasn’t worked, can someone give me another suggestion on how to fix this?

3 Likes

It’s an old issue which seems to be resurfacing. I had this problem for months and suddenly it was gone about half a year ago. Now it’s back.

Anyway the fix can be found here: "Render Device Lost" Fix for RTX

tldr; rename your executable Overwatch.exe to something else and launch that. You need to repeat this every update.

1 Like

This bug was fixed for RTX cards in an Nvidia driver update last year. If you are using the latest Nvidia drivers you no longer need to rename Overwatch.exe or launch directly through the exe. We updated the known issues sticky at the top of this forum.

GeneralAngry does not have an RTX card as well. He/she has Intel® HD Graphics 630.

Rendering device lost has several different fixes, however there are only a limited number of “software” fixes available for this. The error can also be caused by hardware/power issues within the system, so if the steps in the linked article do not help you may need to contact a PC technician or the system manufacturer for further help.

1 Like

5 posts were merged into an existing topic: [Nvidia driver 445.75] Rendering device lost

I got this error, along with a different one. But I am on AMD 5700 XT.

Inspector.Summary:
Overwatch - 1.46.0.0: EXCEPTION_ACCESS_VIOLATION executing 0x00007ffe49eb4800
<:Inspector.Summary>

Inspector.Assertion:
EXCEPTION_ACCESS_VIOLATION executing 0x00007ffe49eb4800

Crashing Thread (ID: 6476)
DBG-ADDR<00007FFE49EB4800>()
DBG-ADDR<000001AA4F5C1D00>()

<:Inspector.Assertion>

I also have this issue it happens almost every other game I tried contacting blizzard support but they have no answers