Unplayable FPS on/after startup

I wasn’t able to make a ticket, (idk why but I can’t attach files or submit anything) so I’ll post it here:

I have a recent problem with fps in Overwatch on my new machine. (Not as new as the problem.)

My machine:
CPU: AMD Ryzen Threadripper 2920X
RAM: 32 GB 1197MHz
(monitor: DELL U2412M (1920x1200 @ 59Hz))
OS HDD: Force MP600 NVMe PCIe Gen4 x4 M.2 SSD
HDD the game is installed on: Force MP600 NVMe PCIe Gen4 x4 M.2 SSD
OS: Windows 10 Home Edition

Sequence when I start up the game:

Bootup Game and lands on 60 fps
Go into training room drop to 15 fps
After training room has loaded for about 10 seconds it sits on 60 fps
When interacting with anything like, hovering over heroes, picking them, shooting, using abilities of any kind for the first time the fps drops to 15 for about 10 seconds.
When entering a game with 12 people it lags incredibly much for half a round.

I have to start up the game, wait for about 10-15 minutes and then launch a game if I want the game to be playable.
No internet problems anywhere else, only few occasional outages.

I have tried:

  1. Checked temperatures:
    CPU: 42°c. MB: 45°c. GPU: 45-51°c.
  2. Scan and repair
  3. Performed a selective startup.
  4. Reset video driver settings
  5. Reinstall game & clear BattleApp cache
  6. Update drivers & Windows
  7. Untick browser hardware acceleration
  8. Reset in game options
  9. Set power management to high performance
  10. Ran the game without background apps

The problem remained. It started weeks ago.
Recently installed old Razer software for a backup mouse. (Synapse2 Legacy) I have uninstalled it and rebooted, the problem remains. Almost certain that was after the fps problem started.
Did not have this problem before, did not have this problem on a previous system with an older GPU (nvidia geforce 970) and less CPU and RAM.

Some BattleApp logs are empty but some of them have these texts:

[1121/131204.497:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/144953.691:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/144953.851:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/145025.601:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/174600.497:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/233538.408:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/233538.529:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1121/234340.171:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6
[1122/000329.449:ERROR:mf_video_decoder.cc(747)] Unsupported codec by MfVideoDecoder: 6

I have been having this exact issue as well.

Can you add a DxDiag? Have you checked hard drive performance? Make sure 12-15% space is free.

I can’t post the entire thing here. So I put it on my OneDrive, but I can’t post links here. How can I show it to you?

And how do I best check my hard drive performance?
chkdsk says there are no problems.
S.M.A.R.T. status says they’re all okay.
Anything else I can do?

If your DxDiag does not fit in one message post it on Pastebin.com and provide the hash code (the numbers/letters after the .com) in your reply. Please don’t use a private hosting site for the DxDiag.

I understand.
Here: biKqtMR4

Händelsenamn: APPCRASH
Svar: Inte tillgänglig
Kabinett-ID: 0

P1: ArmourySwAgent.exe

No errors specific to Overwatch in that report, but this error is appearing a lot. Does it control storage on the PC?

No, that’s Armoury Crate I think, the driver program for the CPU cooler. (a hybrid)
It controls the fans and the ledlights and a small display on the cooler itself.
These ledlights are often buggy.

Since there’s nothing pointing to the crash, I recommend checking the Windows Event Viewer or Reliability History to see what the crash is/why it’s happening.

You can also try the selective startup, where nothing is running other than Overwatch.

Did the selective startup already.
My game isn’t crashing, but it’s laggy and unplayable for the first half of a match. I don’t feel like I should have to wait for the game to catch up…

Can I send the Reliability History .XML somewhere?

It does say Corsair.Service.DisplayAdapter Stoped working about exactly the time I opened the window to see this, but that was after the game had ran for a while.
I’m not sure why though, I have a DELL monitor.

Windows Event Viewer doesn’t say much, but there’s one warning:

Behörighetsinställningarna programspecifik ger inte Lokal behörigheten Aktivering för COM-serverprogrammet med CLSID
till användaren MATRIX\Gamarleton SID (S-1-5-21-2348996806-1642034880-72338804-1001) från adress LocalHost (med LRPC) som körs i programbehållaren Inte tillgänglig SID (Inte tillgänglig). Det går att ändra säkerhetsbehörigheten med hjälp av administrationsverktyget Komponenttjänster.

That’s peripheral software for a Corsair device, like a mouse or keyboard. The display adapter shows stats on the desktop and has been known to cause Overwatch issues.

As for the error, if the translation is correct for me, it says there are permission errors. I can’t tell if it’s for the hard drive or the RAM, but are you using any security apps like Malware Bytes, etc?

I can’t tell either because I don’t understand it.
I’m using Malwarebytes, but I added the entire BattleApp and Overwatch folder (both) to exeptions.
Other than that I’m only using Windows own virus protection.

Overwatch is allowed through my computer firewall, I don’t know if I need to do something on my router but I never had to before?

Edit: I found the “Komponenttjänster” (Component services?) window and looked around a bit, when I clicked DCOM-configuration something something a sign poped up.
I will try to translate it to the best of my knowledge:

CLSID {615AC66B-72C3-4DEB-8F22-19B372142787}, the post C:\Windows\system32\RtkAudUService64.exe with the title RtkAudUServiceCOMObject Class has the nominal value AppID, but is not stored under \HKEY_CLASSES_ROOT\AppId. Do you want to store it?

The options are yes and no. What do?

I don’t know which option to pick. That’s the RealTek audio driver. You could try reinstalling the newest version for your motherboard to see if it fixes the issue. I also recommend temporarily removing Malware Bytes to rule it out.

In the meantime, you may want to open a ticket with the staff to see if they can help narrow this down. I know you said you had trouble doing this, but they can use more in-depth diagnostic files. Make sure all files you attach to the ticket are in .txt format.

Launching with Malwarebytes turned of changes nothing.

I can’t find the RealTek audio driver anywhere online. I never really installed it, I just saw that it had something on Windows 10 already.

How do I update it? Do I need to do something else?

I still can’t submit a ticket, though.
When I first tried to, I tried to include as many logs as I could because they were not saying much. I had to remove some of them. Then something happened to the tab I was on, and I had to re-submit.
After that It’s told me I can only attach 4 files, when I have only attached the DxDiag and trying to attach the msinfo32.

I can’t submit a ticket without attaching them.


Thanks for following up with us on this one! I know it’s not easy dealing with crazy FPS issues on such a powerful system. Here are a few things I wanted to go over on this topic:

This program mostly does fans and stuff but can also be used for Overclocking and tons of other stuff. If it’s throwing errors like the one Nicole mentioned I typically recommend reinstalling it. Opening the program to restore factory settings may also be worth doing, and also testing with the program temporarily disabled. Lots of different tests and things to do with one program but this one can impact a ton of different stuff for performance on the PC.

These would typically be downloaded/installed form the Motherboard Manufacturer website unless it’s an expansion sound card. The DxDiag is only showing “System manufacturer” though so you’d need to check your receipt or look at the device physically for a product description/name (example: Asus Gaming 12345)

Once you have the device info we’d just look it up on the Asus Download Center.

I noticed you mentioned the problem submitting the ticket was with attachments. Could you try attaching a generic text file created using notepad? Feel free to just put “Kaldraydis said to” in the file and save it before uploading. Though if possible please include the msinfo and other files via email to techinfo@blizzard.com - Let the agent know in the ticket text you emailed the files instead of attaching them to the ticket due to an error of some kind.

Notice: The email posted above is only for sending files upon request. If an agent does not request files please do not send anything to the inbox! Replies are not sent through that inbox. Any reply would be through the forum thread or support ticket the agent requested the files on.

If there is still any error sending the ticket, please still send the email with the msinfo. We’ll do our best to help out from there! <3

It appears I can’t quite uninstall Armoury Crate. For whatever reason ASUS made this impossible I don’t know.

And when it comes to ASUS downloading center, I never know what files to download.
Here’s the thing: I don’t actually know all about what I’m doing. I need help with this. Sending me a link to their official webpage with vague directions isn’t gonna help me.
The only reason I know all I already do, is because nobody ever helps me with anything.

Do you mean the device info I wrote up top where I put down my parts and what they’re called? Or do you mean the Part No.: or Serial number?

I don’t understand how you can both quote me and at the same time not read what I’m saying…
I can’t sumbit a ticket.
It won’t let me submit without attaching the two main files, and I can’t attach them both.

That’s why Kaldraydis offered an email option above. Use that instead of the ticket system to submit your files.

Sorry, it’s been a long day trying to solve this myself even before I came here. I sent the email, I don’t know if I wrote it right… I put your name on it and referenced the link to this thread just in case…
Let me know if it reached you.

Edit: I think I managed to uninstall Armoury Crate, but I’m no longer sure if I should reinstall it… it was awful.
Never told it to OC anything, but I guess it still may have?

I did install audio drivers from ASUS official webpage though, and the problem remains.

How do you mean? How do I find out?

It’s also happening to me and I’m pretty sure it started after I updated my GeForce Experience driver to the latest one (which came out 17th I think but I only installed it recently).

I’m a potato so I can’t figure out how to get back to the older version, so I’ll just stick with it until a new update gets released.

After a few minutes, though, FPS stabilize