Rendering device lost

my computer keeps giving me rending device lost in games.
I thought i had it fixed after driver updates, restarts and some quick plays and then jump back in to competitive a bam happens again now I’m banded from competitive for 20 hour and my rank is stupid low which all kinda sucks on top of the game still crashing.

8Gb ddr3 ram
radeon HD 7950


Rendering Device Lost errors are frustrating but there are some key tips to check out here first that might solve your problem:

This is infuriating. I’ve had this problem since launch, I have followed every single guide in the forums to fix this and still no permanent solution.

I just had 2 back-to-back rendering device has been lost errors, and lost 100 SR. due to that. Makes me want to quit the game when I work hard to win 4 games for that 100sr and then I lose it in less than few minutes because this error occurs… Thanks blizz.

1 Like

I strongly recommend starting a web ticket with Blizzard then. Make sure to prepare your MSInfo and DxDiag system files so that they can quickly learn about your computer and see if there are any issues that can still be causing this error. I wish you luck!

The other thing to consider is that the render device lost is the audio, I’ve recently been experiencing this issue and initially assumed that this was a problem with the video device, however in reviewing the error log the only device mentioned was the audio.

I have tried a lot to fix this issue and also tried every available ‘fix’ out there:

What eventually ended up being the fix for me:
Make sure your RAM timings are right. I am using Corsair vengaence ram with a Hynix module instead of Samsung b-die. On my Ryzen system this didn’t allow me to select an XMP profile (which makes sure your ram timings are properly configured) and use 3200mhz for the frequency. I disabled XMP and set it to 2933mhz, because that worked, and let it be.

I now enabled XMP and manually set my ram frequency to 2933mhz. But that’s my specific case. The thing is, if you have not done this yet; enable your XMP profile in your bios to make sure your memory uses the right timings.

You can read a bit more about it in my thread posted above ^^.

Edit: you can use any frequency where your ram runs stable by the way. Mine just happend to be @ 2933mhz…