Primary fire (left click) not working


#1

Hey all,

So since last night my primary fire doesn’t work when the key is mapped to the left click on my mouse (default setting, never changed it before).

  1. First thing I checked was the mouse. I use a corsair mouse that’s barely a year old, but switched to an older Mionix Castor mouse and that didn’t work either.
  2. It wasn’t the USB port because I tried every USB 3.0, USB 2.0, and USB 3.1 port on my MOBO and both mice worked perfectly fine for everything except when I played OW and primary fire still didn’t work.
  3. I checked the drivers for both and they were up to date.
  4. It’s not a touchpad problem because I’m using a custom built PC and not a laptop.
  5. I thought maybe it was an issue with my installed copy of OW, so I did the scan/repair function. That didn’t solve the problem.
  6. I was considering completely uninstalling and reinstalling my copy of the game. But before doing that I just now tried running OW on an older Lenovo thinkpad I have (using geforce NOW), and I’m STILL HAVING THIS ISSUE.
  7. Oddly enough when I reverse my primary/secondary fire keys I have no issues whatsoever (right click for primary fire and left click for secondary fire). This makes literally no sense to me but is even further confirmation that the problem isn’t my mice. I tried playing this way and it was pretty unplayable. I’ve sunk over 600 hours into this game and you can’t just switch off muscle memory.

The only thing I can think of that might be the problem is maybe a bug with the most recent patch. I’ve confirmed the issue isn’t my mice, nor the drivers, nor my computers, nor my own installed copies of them on multiple devices.

Has anyone else run into this problem? This is increasingly frustrating, I can’t seem to find anyone with the same problem online who has a solution and don’t know how to fix this.


#2

Did you try resetting all of your bindings from the menu?


#3

Did you try resetting all of your bindings from the menu?

Wow, that worked! Reset to default and just re-mapped any custom settings I originally had. Odd why that suddenly fixed it but I appreciate the support :slight_smile: