OW2 doesn't launch after pressing play

My game won’t launch after pressing Play. The game attempts to start–a black screen shows on my monitor, but the game closes abruptly. It doesn’t give me an error code either. I’ve tried every possible solution on this support page (Overwatch 2 Doesn't Launch - Blizzard Support) but nothing has worked. I scoured the recent forum posts but found nothing useful. Please help!

Common causes:

  • Razer Chroma
  • nVidia Broadcast
  • 360 Security
  • Avast
  • Sophos
1 Like

I actually read a forum post of yours regarding Razer Chroma and did find leftover files, but I deleted them. Yet, I still have this problem. I just turned everything off on nVidia broadcast, but the game still can’t launch. I don’t have Avast, Sophos, or 360 on my computer.

Add a DxDiag on Pastebin and link here.

If that doesn’t give clues, try an MSInfo also.

1 Like

Here it is: ------------------System Information------------------ Time of this r - Pastebin.com

I have the exact same problem as OP. Please help me fix this.

1 Like

My Issue is sometimes my game starts and sometimes not. The OW process shows up in Task manager but I have to ‘End Task’ in Task Manager several times as I keep trying press ‘play’ on the launcher still it starts. Sometimes I have to just ‘End Task’ on game and launcher, then restart battle.net. Everything is hit or miss. no idea what is causing it. I have tried the solutions on the support page Overwatch 2 Doesn't Launch - Blizzard Support still the problem persists

Also experiencing the exact same problems as OP. Here is the DxDiag for my system if it helps.

You both have the same issue.

There are files remaining.

Problem signature:
P1: Overwatch.exe
P3: 6344b825
P4: RzChromaSDK64.dll_unloaded

The pinned thread has the locations of the files:


Deleting RzChromaSDK64.dll_unloaded worked for me, thank you. Crazy how a leftover file from an uninstalled program interfered with the game.


Worked for me too. My bad, I thought I got every last one. Thanks so much, Nicole!

1 Like

quoting to my post I am updating my DxDiag here

Here is my DxDiag. Same problem as OP please help me.

Almost the same issue, Razer stuff.

Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: GameManagerService3.exe

Correct, it is the exact same problem. You have to hunt down the files.

Problem signature:
P1: Overwatch.exe
P3: 63407107
P4: RzChromaSDK64.dll_unloaded

I won’t be doing any more troubleshooting in this thread because all replies ping the OP, and that’s not fair. If you’re having an issue, please start a new thread with your diagnostic files. Thank you!

where were you able to find that? I have the same problem but i cant find where to delete it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.