Overwatch 2 Randomly Freezes during Gameplay

–tank_WorkerThreadCount 2 try adding this to ur command line on battle net!!!

–tank_WorkerThreadCount 2 this comand is our saving grace, add it to ur command line on battle net

1 Like

The command does not work, the game froze after 2 minutes in the practice zone.

Its still a testing version of game… Should get fixed if it affects atleast 1% of players.

this startup command line solved my problem, it was crashing all the time and now it isnt! “–tank_WorkerThreadCount 2 -thread 2 -d3d11”

If you have a 2-core processor, like an i3 model, you’ll want to chime in here:

If you’re using a Pentium/Pentium Gold processor, please note these processors do not meet the requirements for Overwatch 2.

Hi guys i think i solved the problem, enter task manager, choose services, choose overwatch 2 and right click, set priority, choose high
in setting choose window
sorry for my bad english

Exactly the same problem, it happens often

This is what I did yesterday, I thought I had solved the problem but it just happened to me…

I’ll try this one as well to see if it is functional or not before I head into the thread that Nicole had linked to.

Update: Not fixed, it still froze after - surprisingly - a few seconds when I joined the practice range.

1 Like

why what happen to this game i also keep crashing

Hey guys just wanted to chime in with a solution that seems to have worked for me, went from a freeze every 2 or 3 games to 2 hours straight without a freeze (and counting)

  1. Set this command in battlenet for startup “–tank_WorkerThreadCount 2” though I’m not sure if it’s doing something honestly. There’s an addition to it in this thread you could try.
  2. Run overwatch in high priority from Task Manager. I can confirm this helps with stutters on my machine but unclear if it really helps with total freeze, but do it just in case.
  3. Every chance you get, turn on Dynamic Render Scale, and turn it off again immediately so it prompts you to apply (Y). Apparently there’s a bug that turns this option on, and it seems to be related to the freeze bug, so make sure you don’t play with it on.
    This is working for me (so far) so I hope it helps :slight_smile:

Can’t play the game! Every 5 min or so the game freezes! They uptdated the game yesterday but the problem stills. Thx for nothing blizzard.

1 Like

i did those same steps and it worked, played for over 2 hours and a half without any freezes or crashes, but you do get pretty laggy in the beginning. Thanks!

This is the commando code that worked for me for the past 2 days: --tank_WorkerThreadCount 2 -thread 2
You just have to put in the battlenet launcher’s game configuration: settings->game setting->Additional command line arguments->tank_WorkerThreadCount 2 -thread 2 (you could also try to change the “thread 2” to the number of cores your cpu have, i for example have 4 cores, so i just putted “thread 4” and it works without any issues, if not just keep it at 2)

Well, there’s people with I5 and I7 with +4 cores having the exact same issue… so it isn’t only for i3 model or 2-core


use this all copy paste : --tank_WorkerThreadCount 2 -thread 2 -d3d11
my game was freezing everygame and after this codes never happened try and make sure dynamic render scale off and use low graphics

Sadly this did not fix the issue for me :frowning:

1 Like

This worked for me too!

So for me uninstalling Afterburner and Riva solved the problem so far. Played few hours last night and few hours today, not a single shutter. Hope it stays this way now.