My stats is not updated 2 weeks


#1

Hello. My stats on playoverwatch and overbuff is not updated 2 weeks. I receive a message that my profile is private, but it is public.
My coach need my stats today. Tell, how much time you need to fix this problem?
My profile: Ellie#2300


#2

Go into Overwatch and play a single game of any mode. Then please make sure to sign out and sign back into playoverwatch.com. That should make sure your stats are up to date.


#3

I tried, but it’s not working


#4

Try clearing out your cookies on your internet browser or try checking your profile from an entirely different web browser. Aside from that, I am not sure what else to propose, you may need to export screenshots of your profile in-game to send to your coach in the meantime.


#5

It’s not working too.


#6

Hey Ellie,

Looking at your profile, it does indeed appear to be set to private on the official site. In the Social menu of Overwatch’s in-game options, there should be an option called “Career Profile Visibility”. What is it currently set to?

We don’t have any confirmed or known issues with this option, so worst case scenario, we’d recommend bug reporting and sending screenshots of your profile to your coach as WyomingMyst recommended.

-Lantrasau


#7

Hey. Yep, my profile is public now. And always was.
Two weeks ago, my statistics just stopped updating. Administrators of the overbuff said that the problem is not on their side.
I tried to change the profile to private and restart overwatch, but its not working.
I don’t know what to do. But I heard that there were other players who sent reports on the overbuff with the same problem.


#8

I have the same problem. My profile is also in public but I can’t get updates.
I also posted my problem here a week ago and I haven’t get any response yet.
If you found the solution, please; post it.


#9

Same problem for me. November 5 is when I got my latest stats. Would be great if it could be fixed.


#10

I have tried all of the above (erasing broser cache and cookies, using different browsers - Edge, Chrome, Firefox, Opera)

“Career Profile Visibility” is set to public.

The issue is still happening to a lot of other players:

This is the first thread I see someone from Blizzard answered.

Please help us!