Massive FPS Drops For No Reason

You’ve probably read a lot of these as of late, but I have an MSI gs75 Stealth with a Nvidia GeForce RTX 2070, and up until the last few weeks the game ran fine at about 70-100 fps on max settings, but now all of a sudden, I am getting massive drops. When sitting in the main menu, I’m at about 6-9 fps. I’ve never had this happen in any other game, all the other ones I have like AC Valhalla, Cold War, etc. all run crystal clear at over 80 fps. I really want to play again, but it is unplayable at this point in the game. I went into training and did the ctrl+shift+n thingy I’ve seen from other threads and my latency was between 70-95 ms. I know that’s horrible, but I’m not sure what is causing this because like I mentioned, it was working fine for years. If I could get some help on this that would be great. Thanks.

Are you near any of the winter storms that have been happening? That could increase latency. But that shouldn’t bring your fps to 6-9, that sounds like another issue. Make sure to include your DxDiag for troubleshooting, and also a WinMTR if you have latency concerns.

Instructions at top of forum:

No I’m not near the winter storms. I have followed the DxDiag instructions to save, would you like me to post the file into here?

On Pastebin.com and link it here.

Here is the link where I copied the information

These are the apps that may be causing issues:

Problem signature:
P1: OverwolfLauncher.exe

Problem signature:
P1: GameManagerService.exe

Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Dragon Center.exe

I uninstalled overwolf and razer which was supposedly housing the GameManagerService.exe, but to no avail. I don’t know if i can just delete dragon center as it is the control center where I control fan speed and power for my battery etc.

Are you running on High Performance vs Quality or Balanced?