Long Launch time

Overwatch 2 takes over 1 minute to launch after pressing play.

I have tried everything google could suggest, but I still run into the same problem.
I’ve even tried reinstall the battle.net app and Overwatch 2, even tried an BIOS update to see if that was the issue.

I have a decent desktop PC, so hardware isn’t the issue. Every driver and such is up to date and my m.2 SSD is also not the issue (Checked the state through cmd).

Troubleshooting will require providing the requested files from the pinned threads.

I can’t post the DxDiag text in here because it’s too long.

Use http://Pastebin.com

Since there are BlueScreen codes popping up in the report, it’s likely a problem with the driver or your hardware, which isn’t something that falls under support here. However, I also see your WiFi power management has an error from the ASUS Armory app, so that could be the cause too.

In the meantime, create a custom power plan to run on High Performance, NOT Quality.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.