Invasion DLC Bundle Steam but didn’t receive anything

Just tried this above and it worked for me! Launched OW in battle net didnt have it - closed app switched to steam launched in steam and I got my battlepass and rewards

same here i got the Overwatch® 2 - Invasion Ultimate Bundle but it’s not in my account
and i tried everything :cry:

I switxh in between the two but it didn’t work

Same, tried switching to no avail. The fact that there’s nothing about this other than living in the basement of a known bugs list on a forum no one looks at is nutts

1 Like

Yeah, same here. I bought the Invasion DLC on Steam and haven’t received anything but have been charged.

Steam’s weird policy is that they don’t refund DLC, even if it’s clearly not working. They say as this content is managed by Blizzard they can’t do anything. So it’s just a waiting game for Blizzard I guess.

how long does it usually take for the support team to solve our issue

here i hate this

It’s been over 8 hours since release, and I still do not have the stuff I bought. Watch a terrible launch on Steam.


still broken and I hope we get some compensation for this

Same here, I bought the content on Steam because I cannot wait never to load the Battlenet app again. I linked my Steam account, launched the game, and boom, locked out of content unless purchased from the shop. FML

They are probably waiting it out in case some people who purchased via Steam break down and buy in the shop. It is not refundable.

This really isn’t acceptable Blizzard and isn’t good CS. We require an update on this asap, this is really not on for a company of your size and your are treating this as something of a small issue when its every person on steam that has the issue.

1 Like

I purchased it from the shop and I still don’t have it.

Steam will stop you from buying something you have already purchased unless you are going to buy it for someone else

Mine finally registered with my account.

I got double charged for the $15 missions bundle AND the premium battle pass! :face_with_symbols_over_mouth:

still nothing. it really leaves a sour taste.

Did it just randomly pop or did you refresh the game randomly?

I’ve been in and out of the game all day. It’s finally showed the DLC as being bought.

1 Like

and they reflected that in the game and your happily playing invasion now?