Glitching in and out of Retribution


#11

This happens to me also on Xbox. The Halloween event the same way. Has there been any solution? I love the events but can never play. It only happens to me and not my friends. Very frustrating joining back and all my teammates are dead or report me for leaving lol


(Cathy Lee ) #12

Thank you for that Reddit thread, SpritePR!

For those of you affected by this issue, can you tell me what router you’re using? Name and model number if possible. Also, are you experiencing the issue in story mode, all heroes mode, or both?


#13

Tried the reddit suggestion and although it seemed to work at the beginning, about halfway through started having the same issue with lag and disconnect/reconnect. I do have a netgear router and the model is R6700


#14

Im having the same issue and I have a Net Gear NightHawk R6700v2 router and im wireless issue is still there


(Cathy Lee ) #15

Thanks Kychow17!
Do you remember if you experienced the issue in story mode, all heroes mode, or both?


(Cathy Lee ) #16

Thanks xXCODHawkXx!
Do you remember if you experienced the issue in story mode, all heroes mode, or both?


#17

I’ve had this same issue in both Retribution and Uprising both story and all heroes mode. My router model is a Netgear AC1200. Plz help meee it’s so annoying I can’t get achievements.


#18

mine is not router issue. i can play comp and quickplay for hours on end and not have any problems. only in the 2 new modes do i come across it every match. i dont know whats going here, but its not on my end, or at least to my knowledge


#19

I had the issue on both


(Cathy Lee ) #20

Thanks so much for all the information guys and gals! We’re trying to reproduce the issue on our end and really appreciate the cooperation. Can you also tell me if you were hardwired or wireless when you encountered the issue?


#21

Im currently wireless


#22

I am currently wired


#23

I managed to fix my issues by enabling QoS on my router I’m using a netgear R6220 router.

I’m wired.


#24

im currently wireless


#25

I was wireless when I was doing it, and I only tried the story mode for retribution, none of the other event modes due to the current issue.


#26

Just an update, was able to update my firmware for my router and that with the reddit post fix seems to have worked, just ran through a game of retribution with no issues.


#27

I don’t know if it is me maybe but for no reason during the retribution and the uprising events, when I am in the middle of the game, I will be randomly kicked and it will say client server disconnect, maybe it is a problem with my router but if there is any way to fix it I would love to because I hate having to abandon my teammates especially if we are close to winning.


#28

I also have a Netgear AC1200 and it happens in all modes of Uprising and Retribution. I am hardwired


#29

I have a Netgear R6230 router and the same issue where I get booted to the menu in the event every minute or two. I have a wired connection and the Reddit suggestion of turning QoS on with warcraft set at highest priority worked to fix it for me.


#30

I updated the firmware and changed the QoS settings on my Netgear AC1200 router and still having the EXACT same issues.