"Game is running..." But Overwatch NEVER Launches

My boyfriend gifted me Overwatch Game of the Year Edition for PC last week. The installation went smoothly and I was able to play it right after. But when I tried to play it the next day, Battle.net would say “Game is running…”, go to black screen, and then it would close shortly after.

I have tried scanning and repairing multiple times, uninstalling and reinstalling the game, deleting the cache files as well as the Battle.net folder. I have updated my drivers and have done everything a forum told me to do and nothing is working.


Hey there,

This may be the Razer issue causing the crash on launch. This should help:

If you’re still having issues go ahead and post your DXDIAG:

  1. Press Windows Key + R.
  2. In the Run window type dxdiag and press Enter.
  3. In the DirectX window, click Save All Information.
  4. Name the file “dxdiag” and save it to your Desktop. Open the new dxdiag file with Notepad.
  5. In the posting section here hit the </> button for “Preformatted text” then paste (Ctrl+V) the DXDIAG contents. That’ll make the information much more readable.

If you are unable to post this due to the length of the DXDIAG, please feel free to use pastebin.com and share the link with us instead. Use the </> button as well in order to share the link.