Game crashing on startup

Ive been trying to fix this for a good 2 hours this week and ive gotten no results. Ive googled and googled, tried and tried again but havent found a solution. Basicly the game crashes when i try to start it. There is a black screen for a good 3 seconds and after that the game just closes itself. This began happening after i reinstalled the game to try it out again.

1 Like

Howdy JaBu,

These black screen crashes are typically caused by Razer Chroma, which could have come pre-installed on the computer. It’s also possible that old Razer Chroma files have been left over after uninstalling the Razer software. Try the steps here to make sure the Razer Chroma files have been completely removed. If that doesn’t help, let’s get a DxDiag:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the “preformated text” button (</>). That’ll make the information much more readable.
It should look like this.

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

I didn’t notice anything specific but it looks like the Nvidia driver is showing some errors. Let’s try a clean driver reinstall.

First, remove the current driver files by using the third party driver remover DDU. You can find a guide on using this program here.

After this, pick up the latest driver from here. Run the installer and select the Nvidia Driver option only. Then I would recommend doing a Custom install and selecting the ‘Perform a clean installation’ option.

Once the driver install has finished, change the Nvidia settings so that the game is using the Nvidia card:
• Right click on the desktop and launch NVIDIA Control Panel --> Manage 3D settings.
• Go to Program Settings tab.
• Select the game to change the graphics processor under “Select a program to customize”. If it’s not is not available, select the specific game from the drop down list.
• Select your “Prefer maximum performance” graphics card under “Power management”.

Then reset the game settings to set everything back to default.

Sorry that im responding hella late, i tried everything you said here and the issue didnt fix itself. Still the same problem, game doesnt even launch. I am kinda losing hope for fixing the game…

Scroll to the end of your report, check all of the apps labeled “Ongelman allekirjoitus:” and either stop them from running, or reinstall them. The ASUS GPU tweak app could be causing this, or the wallpaper app (if you’re using slideshow). There is also a possibility than one of those apps is malware, because it records keystrokes/mouse input (Blitz.exe). You may want to run a scan for that.