FPS stuck below 30 since last update on 29th Apr

My setup isnt the best, but usually i get about 60-70FPS when playing Overwatch. Ever since the last update on the 29th, my FPS has been stuck below 30 making the game unplayable. Tried everything- reinstalling drivers, resetting settings on Overwatch, even reinstalling Overwatch- nothing is working. Plus I still get high frames on other games, this is only happening to Overwatch.

1 Like

A while back an issue with Razer Synapse was causing frames to be locked at a low amount. Are you using any of their devices?

Otherwise, please include your diagnostic test in a reply.

I am currently using a Razer DeathAdder Elite. I have tried updating my Razer Synapse 3 to the latest version, removing the programme completely and reinstalling the latest version. The FPS is still locked at under 30fps. Attached the dxdiag:


I don’t see any errors specific to the Overwatch client, but maybe I can point you in the right direction.

There are crashes being reported for several apps below:

Problem signature:
P1: OriginWebHelperService.exe

Origin software, you may want to disable the Web helper module.

Problem signature:
P1: Razer Synapse Service Process.exe

Make sure to pay special attention to the files you may need to remove, mentioned here.

Problem signature:
P1: AsusTPCenter.exe

ASUS Smart Gesture. I don’t have any information on this.

Problem signature:
P1: nvcplui.exe

nVidia control panel is missing or corrupted.

After you follow the Razer steps I mentioned, I recommend downloading Display Driver Uninstaller and removing your GPU drivers. Then you can reinstall the new ones. You may have a corrupted install right now and simply using “clean install” doesn’t remove everything. Also double-check that the nVidia GPU is set as the default for Overwatch inside the nVidia control panel.

If none of this helps, you may want to investigate for overheating due to the amount of apps reporting crashes.