Failed to Connect to Server - not our fault but we still lose SR and get ban

This week, my friend and I get “Failed Connection to Server” before a game even begins, and we lose 50 SR and get a ban. Our internet is way OP and we monitor the internet constantly. We also use TeamSpeak 3 on our own sever, and the connection was not interrupted on there, so we know it’s not on our end, so heck, why are we getting punished for a Blizz server error??? Plz fix / explain. (We are both in DE on 02 network) ;; __ ;;

Update:
It just happened again, same conditions:

  • no problem with my internet, no connection loss, monitoring it
  • my computer is super OP and not an issue
  • private voice chat server not interrupted
  • game screen goes black, doesn’t even start the match
  • “failed connection to sever” for me and my group

this time we got SR demerits and a 3 hour ban. Heck, at this rate, looks like i’m going to quit Overwatch cos this sucks real super bad.

2 Likes

This isn’t a bug, it’s a connection issue. It’s really common for everything else you’re connected on to continue working as normal, but have problems with one individual app or service. This is because not all services take the same path from your ISP and are not hosted in the same cities. More info and full explanation from Blizzard here: Common Technical Issues and Solutions

As for leaver penalties, they are all treated the same, since they can’t monitor if someone pulls their internet plug to avoid loading a game or trying to dodge a loss. Lots more info here: Overwatch Technical Issues, SR Loss, and Leaver Penalties

I see why they treat a leaver and DC the same, but in every case it was before the game even started, so this is super unfair. This also only started happening since the last patch. We also know not to have other internet connected apps running while we play, except our voice chat server, and our internet is totally reliable. It’s not our fault, so why do we get a punishment as if it was? It would be not difficult to detect a DC before the match is even started and not deal out penalties for this. I think this a viable solution to this problem.

What happend to me is:
Even before the I got to the character selection screen, the game stops to connect me to the rest of the group. As a result I got the SR strike and a 10 minute ban. (Nothing crashes)

The internet is stable, overwatch is the only game where this issue appears. This happend to this moment 2 times in the last 7 days.

Is this a known bug/ issue? I don´t see what I can do, especially considering the fact that every other online game I play, never lose the connection, or have problems to connect me to a match, when its ready.

1 Like

same problem happened here

Same on PS4, connectivity is fine & only occurs in Comp for OW

Why do you penalize people that get fail to connect to server, I had a match where I am waiting in the menu searching for a match then 1 second later all the game modes are locked and I think I got a match only to be still in the menu and it saying I’m ban for so minutes and lost 50 SR. I didn’t even get into the game. Like give people a chance to rejoin the match before ripping their SR or don’t penalize people that can’t even get into the match really unfair… I get why Jeff says its hard to discern if you disconnect or are a leaver, but if you didn’t even get into the match and see the enemies/players how hard is it to discern that its a connection issue and not leaver???

At the menu (If you are in a group at least) it does give you a chance to rejoin but fails each time so even then it wont work

In my case this happens even only when OW is open and in a group i am the only one that this will happen to, this only happens in Comp and to say its just a connection issue is ridiculous seeing as how it happens at random for long intervals and once again only with comp