Dropping frames constantly

So this has been happening since the tail end of the Archives Event. I recently got a 144hz monitor, so I set all settings to low to get the most frames out of it. I was getting a pretty consistent 144 frames, but would occasionally drop to 130s. Not that big of a deal, still totally playable, but I wanted to see if I could stop that. So I slowly started turning up settings in MSI afterburner. I was not aware that Overwatch didn’t like extensive overclocking, so I started turning it back down, trying to find the sweet spot. I had it very mildly overclocked before, and no problems, so I was just trying to find what the max overclock I could get without getting the “Rendering device lost” message. Now the problem. After I found the “sweet spot” where the game wouldn’t crash, I get constant, erratic frame drops, even when standing still. It’s always 30-40 frames at a time. If I cap frames to 144, it’ll drop to 100-110. if I set it to 60, it’ll drop to 20-30. If I set it to 200, it’ll drop to 160-170. You get the idea. Now I’ve tried everything I know to solve this, and nothing has worked. I’ve uninstalled MSI Afterburner, un/reinstalled Overwatch and BattleNet, I’ve ran the scan/repair tool, I’ve defragged the drive, I just can’t seem to figure this out. Sorry for the long post. Any help would be appreciated, please and thank you.

CPU - i7-4790k @4.00GHz
RAM - 16gb
GPU - GeForce GTX 970

The DxDiag is a couple thousand over the character limit, so here’s a pastebin link.

https: //pastebin. com/51pv26cD

I think your issue could be related to this:

Oh my god, enabling Chroma effects for Overwatch actually fixed it, I’m an idiot. Thank you. I didn’t think it had anything to do with Razer since it happened with overclocking stuff. Thanks again!

1 Like


Just wanted to make sure you were also aware we are currently investigating this issue and reaching out to Razer about it to see if we can get a resolution.


1 Like