Black screen then crash on launch

uninstall my mouse, and Razer synapse 3?

Just the Razer software.

so, just uninstall synapse 3?

Yes uninstall Razer Synapse 3. Double check to make sure there isn’t any other Razer software on top of that. The Razer Chroma SDK will sometimes install as its own entry.

ok, all of my razer software has been uninstalled. should i try to start game now? or restart my pc?

Go ahead and try starting the game.

1 Like

my game launched and is in the main menu screen. thank you for your help.

3 Likes

Hello. I have the same problem. Razer recently put out an update within the last few weeks that I got tired of putting off and finally let it update. Any idea when this will be fixed on blizzard’s end? I have no intention of uninstalling razer synapse and reinstalling it any time I want to play Overwatch so I’d rather just stop playing for now.

2 Likes

Update on my above. I didn’t realize that Synapse and the SDK were two separate entries under the uninstall programs list. Uninstalling just the core SDK allows for (so far) synapse to function normally with my keyboard and mouse settings while also letting overwatch launch now.

5 Likes

Can confirm this worked for me too. Removed the SDK, made sure Synapse was up to date and Overwatch launched no problems.

1 Like

Thx guys, i removed the Razer Synapse SDK components and the game started ! Didn’t have to restart the computer.

This thread should go up to help so many people that are in the same case.

1 Like

Had the same problem described from ShadowDragon and indeed the problem was Ornata Chroma software. When uninstalling it the problem was solved.

I’m having the same issue, but I don’t have any Razer peripherals or any Razer software installed.

4 Likes

I’ve been playing overwatch since launch, uninstalling Razer software that I’ve never updated to fix a fault in Blizzard’s code that has magically appeared is the stupidest damn thing I’ve heard in 2018 so far. Who is running this clownshoes operation

same problem here… and a few of my friends. no razor software, no solution. complete uninstalls and reinstalls, no fix. searched and deleted all mentions of blizzard, overwatch, battle net, etc. no fix.

2 Likes

i fixed the problem… I reinstalled windscribe and turned ON the VPN set to CENTRAL USA for the first run of the game. Now the game starts without the vpn.

Here are the steps and clues that led me to this…
I opened Geforce Experience and clicked “optimize”
Then clicked “play” to run the game straight from Nvidia Geforce Experience.
This started an attempt to update battle net launcher app which ultimately failed with: BLZBNTBTS0000005D
That seemed odd to me considering running the launcher alone appeared to update fine and function perfectly fine.
I have had some connectivity or maybe location issues due to the ISP where I am… (I’m in Afghanistan, and so is my buddy having this problem)
So I figured I would try running the VPN set to USA and… it worked.

Thanks I uninstalled the Razer SDK components and it works, literally opened a ticket about the same topic, game master didn’t fix it, searched this problem up, 3 seconds and done. Thanks Zhyxen.

Hey guys i am having the same issue, i have tried uninstalling all razer software and disabling AVAST completely, still having the same issue:

1 Like

Hey folks,

This is a super old thread and the problems you’re having may or may not be related. We’ve also learned more information about what’s caused this in the last few months. If you are having black screen crashes on launch and have Razer software on your PC, or did at one point, please follow the steps here. Otherwise, start your own thread with information on what you’ve tried to troubleshoot the problem.