Error with the purchase of Anubarak's Oni Skin


#1

Yesterday I was trying to purchase the Oni Skin of Anub’arak before the new patch would be up. While I was doing it,the game was waiting for authorization when all of a sudden it just shut down alone. When I tried to go back in the game it wouldn’t allow me to buy the skin anymore and it wasn’t in my collection either! Already talked with support and, as I said to them, I don’t even mind about the shards lost, because that’s easily recovered with loot chests, but I want the skin that I crafted and never received neither was I given the opportunity to try to craft it again! As I also said to support, I wouldn’t even mind to pay for the skin if needed. Thanks for your concern and hope to see this solved as soon as possible.


#2

Hey Dodellinger,

Thanks for the report! What time did you attempt to craft the skin? US and EU regions patched yesterday and it sounds like it may have occurred right as you were crafting the skin. Because the Anub’arak skin is a Seasonal item it would not be craftable after the patch. Please check to see if your shards were refunded later as well, as sometimes failed purchases can take a while to refund. Additionally, does the item appear in your Transaction History in your Account Management?

Thanks,
~ Fizivix


#3

Hi Fizivix!

It was around 5PM (CEST) so I guess it would still be available at that time. There is no way that I can get my skin back then? No,neither does it appear there but somehow the shards were lost. Already got them back though but with no skin that’s just a bittersweet feeling…