"Queen Ashzara" Heroic mode not available

I have won the bounty in Normal mode, so it should become available for Heroic mode. It does not. Unfortunately it is not allowed to show screenshots, so I will describe it:

Here’s what happened:

  1. Beat “Fish of N’Zoth” Normal mode → “Fish of N’Zoth” Heroic mode + “Queen Ashzara” Normal mode becomes available
  2. Beat “Queen Ashzara” Normal mode → “Queen Ashzara” Heroic mode NOT AVAILABLE, but next bounty “N’Zoth” Normal mode available

Since the Heroic mode of any bounty usually becomes available to play once you beat it in Normal mode, this must be a bug.

How I tried to resolve it:

  • tried beating “Queen Ashzara” Normal mode again, did not work
  • restart app, did not work
  • tried Scan & Repair, did not work
  • restarted computer, did not work

Any ideas?

1 Like

It is a bug, but you can unlock it by completing Fish of N’Zoth in Heroic mode.

The bug and the workaround for it have already been described correctly, however, there is something I would like to point out. This particular problem rings a bell:

‘Resolved’, yeah :smirk:, and definitely not recurring in some form, not even now.